href=file://Q:/Demo_TX/menu.html does not produce any result

RESOLVED DUPLICATE of bug 84128

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 84128
14 years ago
9 years ago

People

(Reporter: Jim Goode, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Coding an anchor in the html to reference a file does not produce any result. No
error, no new page, nothing. Example: <a href="file://Q:/Demo_TX/menu.html">TAKS
Demos</a>

Keying the value into the URL window and clicking Search does work. Example:
file://Q:/Demo_TX/menu.html

The status bar displays the following when moving the cursor over the link on
the page. Example: file:///Q:/Demo_TX/menu.html

The html coding works on I.E. 6.0, Netscape 4.72, and Opera 7.23. The code fails
on Mozilla 1.6, Netscape 6.22 and Netscape 7.1.

Reproducible: Always
Steps to Reproduce:
1. Open my main page: http://int.gotolearn.org/index.html
2. Click on the anchor link described above
3.

Actual Results:  
Nothing

Expected Results:  
Displayed the //Q:/Demo_TX/menu.html page

We have to produce html that runs on all browsers. It seems that this coding
should be handled in a standard manner across all browsers.
> No error, no new page, nothing

There should be a security error in the javascript console, no?  Something about
remote content linking to local content?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> > No error, no new page, nothing
> 
> There should be a security error in the javascript console, no?  Something about
> remote content linking to local content?

Yes. The following:
Security Error: Content at http://int.gotolearn.org/ may not load or link to
file:///Q:/Demo_TX/menu.html.
Error: uncaught exception: Load of file:///Q:/Demo_TX/menu.html denied.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.