If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Click FORWARD should always place cursor on ADDRESS line

RESOLVED DUPLICATE of bug 222533

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 222533
14 years ago
9 years ago

People

(Reporter: Joe Mehaffey, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040421

The FIRST time you do a FORWARD after loading the mail client, the mouse pointer
always defaults to the ADDRESS LINE which makes it easy to enter your address
quickly and move on.  

Subsequent times after the first,  the mouse pointer most likely will land up in
the header requiring manual movement and a mouse click to put the pointer where
the address can be input.

The mouse pointer should ALWAYS default to the ADDRESS line when doing a FORWARD
message function.

Reproducible: Always
Steps to Reproduce:
1.Try and input multiple forwards in a series sequence.
2.
3.
Actual Results:  
see above.

Expected Results:  
see above.

This undesirable operation started in version 1.5 somewhere and has not yet been
corrected in 1.7rc1.

Comment 1

14 years ago
The "mouse pointer"?  Don't you mean the "caret" (aka cursor) -- the blinking 
indicator showing where your next typed character will go?

I do not see this symptom occuring in 1.6 or 1.7b or 1.8a.  The caret always 
lands in the first To: box when I forward, whether as attachment or inline, 
whether composing in HTML or plain text.

What theme are you using?
(Reporter)

Comment 2

14 years ago
Oops..
Sorry, I was not explicit enough.  Please look at the screen photo at:
http://www.gpsinformation.org/joe/misc/mozilla17rc1mailaccterror2.jpg
Notice that there is NOT a blinking (steady or otherwise) cursor (or blinking
indicator as suggested) just to the right of the little square BOX which is just
to the right of the To:

This is the SECOND OR THIRD OR FOURTH time in an email session that you try and
FORWARD an email (say to the anti=spam system).  The very FIRST time you try to
forward the email,  then the cursor (or blinking indicator) is indeed in exactly
the right spot just to the right of the little square box.

The problem is:  When I collect my mail for the day I often have 30 to 40 emails
waiting for me at a time.  Some of these must be forwarded to others,  some I
want to forward to my anti-spam filter so I will not get that sort of mail
again.  It would be very nice if EVERY TIME I click FORWARD, the little vertical
bar cursor would magically appear in the right place for beginning to type in a
new email address just as it does the very FIRST time you do a forward in a mail
session.

I think you can see the theme I am using from the photo.  I do not know the
proper name of it.  The Mozilla system is 1.7rc1.

Comment 3

14 years ago
(In reply to comment #2)
> I think you can see the theme I am using from the photo.

That's the Modern theme.

Even tho I'm duping this, I'm going to update the summary anyway.  :)

*** This bug has been marked as a duplicate of 222533 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: Click FORWARD should always default mouse pointer to ADDRESS line → Click FORWARD should always place cursor on ADDRESS line
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.