{inc} Cell in nested table with percentage width specified has a different width on reload

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Kevin Pontzloff, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.12 KB, text/html
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040422
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040422

In the page at http://www1.wowway.com/wowstory.asp?id=1001 the style sheet menu
on the left overlaps the main body on the right.  I tried it in Microsoft
Internet Explorer 6.0 and Opera 7.5, and the menu fits itself within bounds on
the left without interfering with the text on the right.

Reproducible: Always
Steps to Reproduce:
1.Simply go to the url http://www1.wowway.com/wowstory.asp?id=1001  (no special
setup required)
2.
3.

Actual Results:  
The page comes up incorrectly.  Menu covers part of the text of the webpage

Expected Results:  
The menu should have appeared narrower staying within its defined bounds on the
left column and the main body on the right column would display all of the text
un-interfered with by the menu

I used the default theme of mozilla, and no configuration changes were made
beyond the defaults.  No extensions were added.

Updated

14 years ago
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: general
Version: unspecified → Trunk
Either a tables bug (since that table is being wider than the width is set to),
or evang.  I'm guessing the former, since I see this even with small fonts set.

That said, a minimal testcase is what's needed here.
Assignee: general → nobody
Component: Browser-General → Layout: Tables
Keywords: qawanted
QA Contact: general → core.layout.tables

Comment 2

14 years ago
Created attachment 147182 [details]
testcase

Comment 3

14 years ago
Created attachment 147183 [details]
testcase

That wasn't supposed to be XML...
Attachment #147182 - Attachment is obsolete: true

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted → testcase
Summary: menu on left of screen overlaps body on the right with no way to move it → {inc} Cell in nested table with percentage width specified has a different width on reload

Comment 4

12 years ago
I see stuff like this too, and it often shows errant behavior, like disappearing
on a reload. It looks to me like in:

..
<table id="1">
..
<tr>
<td colspan="8"><table id="2" border="0" cellpadding="0" cellspacing="0"
width="100%"><tr>
..

the 100% in table #2 at some point during loading refers to the width of table
#1, not to the table cell, and that this is corrected only sometimes at the end
of loading the page, especially when loading takes long due to being produced by
a script 
I see no difference in the testcase rendering between:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)

In both cases, the green area does not change size when doing a reload or shift-reload

Comment 6

11 years ago
Yes, seems to work now on Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20061209 Minefield/3.0a1.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.