Menu built with CSS works in mozilla 1.7b and earlier releases, when loaded with 1.7rc1 menu layout is skewed.

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: r may, Assigned: dbaron)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421

http://www.r-may.net
In this page there are a series of dates which when moused over pop down titles.
 When these titles are moused over thumbnails of the image they link to pop up.
 In Mozilla 1.7b and earlier releases (even apple's safari) this works as
described.  When browsing with mozilla 1.7rc1 the thumbnails which are normally
hidden until they are revealed by mousing over titles, aren't hidden or placed
in their proper position.  once you mouse over the the menu item which should
reveal the thumbnail the image is shifted into place.

Reproducible: Always
Steps to Reproduce:
1.load the page
2.mouse over the dates (2004 is still empty)
3.

Actual Results:  
same as described under 'Details'

Expected Results:  
I expected the menu to render the same way it has with previous versions of mozilla.

I have not tested this with Windows versions of mozilla, only on MacOSX versions.
The issue is that Mozilla up to version 1.7b had a bug -- it allowed invalid ID
selectors (bug 239079).  Fixing this bug is what broke this site (at least the
two happened on the same day).  When I load the site in a debug build I get:

CSS Error (http://www.r-may.net/main.css :237.22): Expected identifier for ID
selector but found '#1997'.  Selector expected.  Ruleset ignored due to bad
selector.
CSS Error (http://www.r-may.net/main.css :249.6): Expected identifier for ID
selector but found '#1997'.  Selector expected.  Ruleset ignored due to bad
selector.
CSS Error (http://www.r-may.net/main.css :271.6): Expected identifier for ID
selector but found '#1997'.  Selector expected.  Ruleset ignored due to bad
selector.
CSS Error (http://www.r-may.net/main.css :280.6): Expected identifier for ID
selector but found '#1996'.  Selector expected.  Ruleset ignored due to bad
selector.
CSS Error (http://www.r-may.net/main.css :289.6): Expected identifier for ID
selector but found '#199x'.  Selector expected.  Ruleset ignored due to bad
selector.
CSS Error (http://www.r-may.net/ :4.2): Expected ',' in media list but found
'.'.  Unexpected token within @import: '.'.  Unrecognized at-rule or error
parsing at-rule '.'.

[The last error is unrelated to this bug.]

Note that the CSS spec clearly says:  

   In CSS 2.1, identifiers  (including element names, classes, and IDs in
   selectors) can contain only the characters [A-Za-z0-9] and ISO 10646
   characters U+00A1 and higher, plus the hyphen (-) and the underscore (_);
   they cannot start with a digit.

So I think this is invalid....

Comment 2

14 years ago
WFM LInux 2004052405
Off hand I don't see any invalid IDs.  I assume the site has been fixed.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> WFM LInux 2004052405
> Off hand I don't see any invalid IDs.  I assume the site has been fixed.

yeah,  had some identifiers that started with digits, corrected that and
everything lines up again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 4

14 years ago
reopening to mark as WORKFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 5

14 years ago
Marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.