Vary favicon based on some bug field (e.g. status)

RESOLVED WONTFIX

Status

()

bugzilla.mozilla.org
General
--
enhancement
RESOLVED WONTFIX
14 years ago
7 years ago

People

(Reporter: Kim Scarborough, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040315
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040315

According to bug 175710, it is theoretically possible to have Bugzilla change
the favicon based on the bug status. If that is indeed true, can we have this
implemented for b.m.o.? If it's not, I'll follow up to 17510.

Reproducible: Always
Steps to Reproduce:
"It's possible" in the sense of "it's possible to write code to do it". It's not
just a switch you throw.

I'd follow up in the other bug if I were you.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Did you read the other bug? It says that you can do it by editing
global/site-navigation.html.tmpl. Is that incorrect? If not, wouldn't this be
the bug to request it in rather than that one (since this isn't a request to
change Bugzilla per se but rather a request change for *this specific
installation* of Bugzilla).

Let me know where I've gone wrong here.
(Reporter)

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(In reply to comment #2)
> It says that you can do it by editing
> global/site-navigation.html.tmpl. Is that incorrect? If not, wouldn't this be
> the bug to request it in rather than that one (since this isn't a request to
> change Bugzilla per se but rather a request change for *this specific
> installation* of Bugzilla).

Yeah, that sounds about right.  Do we want it here?

This *may* require waiting for the Bugzilla upgrade, because I think the CSS
stuff to allow that went in after b.m.o's last upgrade.  But if the
powers-that-be decide we don't want this on b.m.o, then it's a moot point.
Assignee: endico → myk
QA Contact: myk → justdave
My view was that the most useful thing would be a different favicon.ico based on
the bug number % 10. That makes it easier to distinguish bugs when you have a
lot open in tabs - "it was the purple one". I can't see much use for being able
to look at a tab bar and say "ooh, I have three CLOSED bugs open".

Gerv
(Reporter)

Comment 5

13 years ago
That would be redundant in every case except when you have a lot of tabs open,
since the bug # is also in the title (unlike the status). Having the icon depend
on bug status would enable people to get *new* information (i.e., in bookmark
lists).
Could you explain more?  By "bookmark lists", do you mean consecutive bookmarks
in the Bookmarks menu or personal bookmarks toolbar of a web browser?  I
understand Gerv's use case fairly well, but this one is less clear to me.

In any case, the favicon is a small but valuable piece of information on tabs,
in the location field, and in bookmarks for popular browsers.  We should
consider its use carefully, since the first thing we pick will stick pretty hard.

I'm open to suggestions besides the two proposed so far... f.e. custom icons
just as we have custom aliases for commonly accessed bugs, or color-coded icons
for bugs' general condition (i.e. green for bugs with recent
confirmation/triage/patching/review/checkin, yellow for stale ones, and red for
the morbidly stale), or priority, etc.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this not right now? Looks good to me.
Chromatabs[0] colours tabs based on a hash of the URL - which is basically like my %10 proposal, but more generally implemented. However, with chromatabs, all Bugzilla bugs come out the same colour, presumably because it doesn't take URL parameters into account.

Gerv

[0] https://addons.mozilla.org/firefox/3810/
Taking all of myk's bugs in the Other b.m.o issues component that he isn't actively working on, since he's no longer the default assignee for this component, and these were all filed while he was.
Assignee: myk → justdave
QA Contact: justdave → reed
Rearranging this component to not have me as the default assignee, so that it doesn't appear like I'm intending to work on bugs that other people could be taking care of if they didn't think I was already doing them.  If this bug is a software issue on b.m.o and you'd like to fix it, the modified source is now available for the patching (see bug 373688).  Reassigning to the new default owner.
Assignee: justdave → nobody
QA Contact: reed → other-bmo-issues
Summary: Different favicon.ico based on bug status? → Vary favicon based on some bug field (e.g. status)
sorry, this isn't something that we're interested in on BMO --> wontfix

this functionality is well suited to a firefox extension based implementation.
Status: NEW → RESOLVED
Last Resolved: 14 years ago7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

7 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.