select doesnt scroll or highlight beyond frame horizon

RESOLVED DUPLICATE of bug 215830

Status

()

RESOLVED DUPLICATE of bug 215830
15 years ago
15 years ago

People

(Reporter: dlai, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

both mozilla 1.7b and firefox 0.8 show this bug, on windows 2000

A select element of a form doesnt appear to function properly when it is near
the bottom of a frame


Reproducible: Always
Steps to Reproduce:
If you load the above URL, it will bring up a form in the upper frame.
If the browser window is narrower than the form, a left/right scrollbar
will appear at the bottom of the frame.  On the right of the frame will
be an up/down scrollbar.  Move the up/down scrollbar to the uppermost position,
in this case the form select elements are snug against the bottom of the
frame.  Clicking on the select (example the List by Name) doesnt allow you to
make selections in a friendly way - ie. there is no highlighting, and the select
scrollbar appears to not work.  In fact the scrollbar does work, but the select
area just doesnt update.

You can see the proper behavior by scrolling the up/down scrollbar on the right
of the frame to the lowest postion.  Now the select elements work as expected.

It only appears to be a problem when the select elements are snug against the
left/right scrollbar.  If the browser window is made wider so the left/right
scrollbar goes away, then the bug also goes away.


Actual Results:  
select doesnt scroll, highlight, or update.  but does appear to function OK
without reasonable user feedback.

Expected Results:  
It only appears to be a problem when the select elements are snug against the
left/right scrollbar.  If the browser window is made wider so the left/right
scrollbar goes away, then the bug also goes away.

Comment 1

15 years ago
WFM, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040424

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 215830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.