If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make sure we respect locked prefs throughout UI

RESOLVED FIXED in Firefox1.0beta

Status

()

Firefox
Preferences
P1
normal
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: mconnor, Assigned: mconnor)

Tracking

(Depends on: 1 bug, {fixed-aviary1.0})

unspecified
Firefox1.0beta
fixed-aviary1.0
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

14 years ago
Connection settings is known (bug 241416).  Anywhere else where we manually do
disabling should be checking getPrefIsLocked().  Ben has some prefwindow changes
coming, once the UI stabilizes we should go through anything using disabling to
add these checks.
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
(Assignee)

Updated

14 years ago
Blocks: 241532
(Assignee)

Comment 1

14 years ago
*** Bug 241743 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
No longer depends on: 241416
Flags: blocking1.0+
Flags: blocking-aviary1.0RC1+
did Ben's pref-ui changes land yet?
(Assignee)

Comment 3

13 years ago
blake's doing it, and not yet, anxiously awaiting.
Mike, I don't think blake is actually working on this, we need this ASAP. 
(Assignee)

Updated

13 years ago
Priority: P2 → P1
(Assignee)

Updated

13 years ago
Whiteboard: [eta 2004-08-02]
(Assignee)

Comment 5

13 years ago
patch is mixed in with 230462
(Assignee)

Updated

13 years ago
Keywords: fixed-aviary1.0
Whiteboard: [eta 2004-08-02]
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Depends on: 273287

Updated

13 years ago
Depends on: 273291
(Assignee)

Comment 6

11 years ago
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.