Webdav publishing doesn't work via HTTPS / SSL

VERIFIED INVALID

Status

--
enhancement
VERIFIED INVALID
15 years ago
7 years ago

People

(Reporter: m.echerer, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316 MultiZilla/1.6.3.2a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316 MultiZilla/1.6.3.2a

Tried to setup a Tomcat with Webdav support first. Worked. Basic auth enabled.
Worked. 
Switched to a https port. Didn't work anymore. 

Calendar response: 
Result: <empty result>

guess it can't handle ssl properly, or it's because I just used a test
certificate where you usually need a dialog to confirm to accept it.

Anyone successfully used webdav via https? 

I guess since this is a easy to install protocol on either Apache/Tomcat, IIS or
whatever it seems more important than any other server support. But as long as
there's no "secure" way to connect remotely, this publishing feature is just a
neat gimmick you can't resonably use.

Would be great to have webdav via https since this is a combination that would
work almost under every circumstances.

So maybe more a feature request than a bug...

Reproducible: Always
Steps to Reproduce:
1. Setup webdav server with https
2. Setup calendar to use the new https & port
3. publish or refresh calendar file via webdav

Actual Results:  
Popup screen.

Result: <blank>

Expected Results:  
Successful sync
(Reporter)

Updated

15 years ago
Severity: normal → enhancement
(Reporter)

Comment 1

15 years ago
my fault
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → VERIFIED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general

Comment 3

7 years ago
How this earned an INVALID is beyond me. 8 years after original filing, the enhancement isn't made. It would be very helpful!
You need to log in before you can comment on or make changes to this bug.