file | open crashes browser

VERIFIED DUPLICATE of bug 240798

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 240798
14 years ago
7 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

here's where I crash:

NTDLL! 77fa144b()
nsDebugImpl::Assertion(nsDebugImpl * const 0x00267e00, const char * 0x020fbebc
`string', const char * 0x020fbef8 `string', const char * 0x020fbf08 `string',
int 711) line 287
nsDebug::Assertion(const char * 0x020fbebc `string', const char * 0x020fbef8
`string', const char * 0x020fbf08 `string', int 711) line 109
nsCOMPtr<nsILocalFile>::operator->() line 711 + 34 bytes
nsFilePicker::ShowW(nsFilePicker * const 0x036599a8, short * 0x0012d7ec) line
130 + 11 bytes
nsFilePicker::Show(nsFilePicker * const 0x036599a8, short * 0x0012d7ec) line 378
XPTC_InvokeByIndex(nsISupports * 0x036599a8, unsigned int 17, unsigned int 1,
nsXPTCVariant * 0x0012d7ec) line 102
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode
CALL_METHOD) line 2027 + 43 bytes
XPC_WN_CallMethod(JSContext * 0x023f7940, JSObject * 0x03153020, unsigned int 0,
long * 0x03660e8c, long * 0x0012dab4) line 1287 + 14 bytes
js_Invoke(JSContext * 0x023f7940, unsigned int 0, unsigned int 0) line 1281 + 23
bytes
js_Interpret(JSContext * 0x023f7940, long * 0x0012e4e8) line 3366 + 15 bytes
js_Invoke(JSContext * 0x023f7940, unsigned int 1, unsigned int 2) line 1301 + 13
bytes
js_InternalInvoke(JSContext * 0x023f7940, JSObject * 0x03152f38, long 51720008,
unsigned int 0, unsigned int 1, long * 0x0012e74c, long * 0x0012e748) line 1378
+ 20 bytes
JS_CallFunctionValue(JSContext * 0x023f7940, JSObject * 0x03152f38, long
51720008, unsigned int 1, long * 0x0012e74c, long * 0x0012e748) line 3618 + 31 bytes
nsJSContext::CallEventHandler(JSObject * 0x03152f38, JSObject * 0x03152f48,
unsigned int 1, long * 0x0012e74c, long * 0x0012e748) line 1292 + 33 bytes
nsJSEventListener::HandleEvent(nsJSEventListener * const 0x02584040, nsIDOMEvent
* 0x03660870) line 174 + 51 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x025a3040,
nsIDOMEvent * 0x03660870, nsIDOMEventTarget * 0x03630ed8, unsigned int 8,
unsigned int 7) line 1434 + 20 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x02588dd8,
nsIPresContext * 0x02bf2b18, nsEvent * 0x0012f2ec, nsIDOMEvent * * 0x0012ed8c,
nsIDOMEventTarget * 0x03630ed8, unsigned int 7, nsEventStatus * 0x0012f33c) line
1529
nsXULElement::HandleDOMEvent(nsIPresContext * 0x02bf2b18, nsEvent * 0x0012f2ec,
nsIDOMEvent * * 0x0012ed8c, unsigned int 7, nsEventStatus * 0x0012f33c) line 2790
nsXULElement::HandleDOMEvent(nsIPresContext * 0x02bf2b18, nsEvent * 0x0012f2ec,
nsIDOMEvent * * 0x00000000, unsigned int 1, nsEventStatus * 0x0012f33c) line
2622 + 50 bytes
PresShell::HandleDOMEventWithTarget(PresShell * const 0x02b71aa0, nsIContent *
0x0252de38, nsEvent * 0x0012f2ec, nsEventStatus * 0x0012f33c) line 6108
nsMenuFrame::Execute(nsGUIEvent * 0x0012f780) line 1650
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x036372a0, nsIPresContext *
0x02bf2b18, nsGUIEvent * 0x0012f780, nsEventStatus * 0x0012f560) line 447
PresShell::HandleEventInternal(nsEvent * 0x0012f780, nsIView * 0x0364f6d0,
unsigned int 1, nsEventStatus * 0x0012f560) line 6072 + 39 bytes
PresShell::HandleEvent(PresShell * const 0x02b71b14, nsIView * 0x0364f6d0,
nsGUIEvent * 0x0012f780, nsEventStatus * 0x0012f560, int 0, int & 1) line 5921 +
25 bytes
nsViewManager::HandleEvent(nsView * 0x0362fc38, nsGUIEvent * 0x0012f780, int 0)
line 2236
nsViewManager::DispatchEvent(nsViewManager * const 0x02b449e8, nsGUIEvent *
0x0012f780, nsEventStatus * 0x0012f658) line 1976 + 20 bytes
HandleEvent(nsGUIEvent * 0x0012f780) line 79
nsWindow::DispatchEvent(nsWindow * const 0x0362fcf4, nsGUIEvent * 0x0012f780,
nsEventStatus & nsEventStatus_eIgnore) line 1067 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f780) line 1088
nsWindow::DispatchMouseEvent(unsigned int 301, unsigned int 0, nsPoint *
0x00000000) line 5189 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, unsigned int 0, nsPoint *
0x00000000) line 5444
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 2818115, long *
0x0012fc28) line 3975 + 28 bytes
nsWindow::WindowProc(HWND__ * 0x000705ee, unsigned int 514, unsigned int 0, long
2818115) line 1349 + 27 bytes
USER32! 77e3a2d0()
USER32! 77e145e5()
USER32! 77e1a816()
nsAppShellService::Run(nsAppShellService * const 0x00f74e38) line 524
main1(int 2, char * * 0x00264f70, nsISupports * 0x00eb32b0) line 1302 + 32 bytes
main(int 2, char * * 0x00264f70) line 1779 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 7c5987e7()

mDisplayDirectory is null
this is from my win2k debug build

from JS, someone is calling SetDisplayDirectory(), which sets mDisplayDirectory
to null.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 240798 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.