A bad search URL is created if non-ASCII characters are entered into the google search box (which by default expects UTF-8) so google truncates the badly coded characters.

VERIFIED DUPLICATE of bug 225695

Status

()

Firefox
Toolbars and Customization
--
major
VERIFIED DUPLICATE of bug 225695
14 years ago
11 years ago

People

(Reporter: pg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Searching for a Hungarian character 'é' produces the following bad query:
http://www.google.com/search?q=%E9&sourceid=mozilla-search&num=20
instead of:
http://www.google.com/search?q=%C3%A9&sourceid=mozilla-search&num=20
or:
http://www.google.com/search?ie=UTF-8&q=%C3%A9&sourceid=mozilla-search&num=20
(The default input charset of google is UTF-8) 




Reproducible: Always
Steps to Reproduce:
1. write a non-ascii character in the google search box and press enter.

Actual Results:  
google changes the character to a '?' (question mark), so the query is malformed


Expected Results:  
use UTF-8 for google queries
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040427
Firefox/0.8.0+

Reporter please use a current build to verify your problem. Your version is
outdated.
fixed by a patch in bug 225695, marking duplicate.
Works in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040429 

*** This bug has been marked as a duplicate of 225695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.