Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
14 years ago
3 years ago

People

(Reporter: Chua Chee Wee, Unassigned)

Tracking

unspecified

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8a) Gecko/20040419
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8a) Gecko/20040419

In the page at http://www.zvon.org/xxl/JSDOMFactory/mozilla/novice.html, the
page is not rendered properly.

Reproducible: Always
Steps to Reproduce:
1. Open browser
2. Paste address into URL, http://www.zvon.org/xxl/JSDOMFactory/mozilla/novice.html
3.

Actual Results:  
Only a coloured background at the top, with Go, Help and zvon.org

Expected Results:  
Render it properly
The rendering is correct.  All the rest of the content is visibility:hidden, and
the script that tries to change the visibility runs into an exception when
trying to access properties of |d4| (which is null).

The reason |d4| is null is that |d4 = document.getElementById("box4")| doesn't
find such a node, because it's the child of an <iframe> tag.

The real problem is that someone forgot to put an </iframe> tag in the source
(or more to the point, thought that <iframe /> is a closed tag in HTML -- it is
not).
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
OS: Windows Server 2003 → All
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Version: Trunk → unspecified

Comment 2

14 years ago
contacted.

bz, it does seem a little weird that the children of the iframe are not
accessible via the dom.
http://www.w3.org/TR/html401/present/frames.html#edef-IFRAME doesn't really say
that the children should be excluded from the DOM, only that they should not be
visible. 
Status: NEW → ASSIGNED
Target Milestone: --- → Jun
Bob, they should also not have any effect on the document (scripts should not
run, styles should not be applied).  At the moment we implement that by parsing
the contents of an iframe as CDATA.

The HTML spec predates the DOM, so it can't possibly say anything about the
DOM....  In an XML document, they would in fact be present in the DOM in our
implementation.

In any case, that's all tangential -- a lot of the page content is just inside
the <iframe> and shouldn't be...

Comment 4

14 years ago
Oh my, anybody using this old code which died several years ago with new
milestone of Mozilla? ^_^" To say the truth I would like to see JSDOMFactory
where it belongs - in the graveyard of history. It was never finished, released
prematurely and after release there was never time to look at it again.
Unfortunatelly it's not that easy... I'll try to get rid of this problem with
ZVON.org people.

Comment 5

14 years ago
[bug248549notfixed]

Comment 6

5 years ago
URL is obsolete.
[closeme]

Comment 7

5 years ago
Uhh, but the site is still buggy.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.