Host names cease resolving (seemingly) at random...

RESOLVED DUPLICATE of bug 240759

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 240759
14 years ago
13 years ago

People

(Reporter: Henrik W Lund, Unassigned)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040410
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040410

Sporadically while browsing, Mozilla will cease activity and claim to be
"resolving host". Whilst in this state, I can not fetch or compose mail, or do
anything that requires the resolving of DNS hostnames.

Reproducible: Always
Steps to Reproduce:
1. Open up http://www.kvasir.no
2. Enter a search string
3. Click "Søk"

Actual Results:  
Mozilla stopped loading the webpage. A "Stop" and "Reload" lead to it reporting
to be "resolving host". This state persisted indefinitely.

Expected Results:  
Mozilla should have resolved the host name (if not from DNS, then at least from
its cache) and loaded the webpage.

A (barely) usable workaround is restarting mozilla. Care should be taken to
manually kill the mozilla-bin process, as this does not automatically happen.
Another workaround is to stop the loading of all webpages, wait for about a
minute or so, then refresh. This will sometimes cause the offending webpage to
load, sometimes not. Note: the supplied test case never, ever loads.

It seems that sites using a lot of banner ads induce the state more often than
others (the supplied test case being an exception).
(Reporter)

Comment 1

14 years ago
about:buldconfig : 

Build platform
target
i386-unknown-freebsd4.9

Build tools
Compiler 	Version 	Compiler flags
cc 	gcc version 2.95.4 20020320 [FreeBSD] 	-Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -Wno-long-long -O -pipe -march=pentiumpro -pipe
c++ 	gcc version 2.95.4 20020320 [FreeBSD] 	-fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-long-long -O -pipe -march=pentiumpro -pipe
-I/usr/X11R6/include -I/usr/X11R6/include

Configure arguments
--disable-auto-deps --enable-chrome-format=jar --disable-cpp-exceptions
--disable-cpp-rtti --enable-crypto --disable-debug --disable-gtktest
--disable-freetypetest --disable-installer --disable-glibtest
--enable-double-buffer --enable-mathml --disable-md --disable-pedantic
--disable-bidi --disable-plaintext-editor-only --enable-strip --enable-svg
--disable-tests --disable-xterm-updates --enable-xinerama --with-system-zlib
--with-system-jpeg=/usr/local --with-system-mng=/usr/local
--with-system-png=/usr/local --with-pthreads --enable-ldap --enable-mailnews
--enable-extensions=default,irc,xmlterm --disable-jsd --disable-dtd-debug
--enable-default-toolkit=gtk2 --enable-xft --enable-reorder
--x-libraries=/usr/X11R6/lib --x-includes=/usr/X11R6/include --prefix=/usr/X11R6
--build=i386-portbld-freebsd4.9 

Comment 2

14 years ago
related to bug 240759?

Comment 3

14 years ago
(In reply to comment #2)
> related to bug 240759?

Very likely. Reporter, the fix will be in Mozilla 1.7 (it's already inside
1.7RC1, and on the latest trunk-builds).

*** This bug has been marked as a duplicate of 240759 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.