'copy [link|image] location' should say 'copy [link|image] address'

VERIFIED WONTFIX

Status

()

Firefox
Menus
--
enhancement
VERIFIED WONTFIX
14 years ago
12 years ago

People

(Reporter: Az, Assigned: Blake Ross)

Tracking

({polish})

unspecified
polish
Points:
---
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [have patch] - need review ben)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In the context menu, when right clicking a link, the option for copying the
address of the link reads 'Copy Link Location'. I believe it would be clearer if
it read 'Copy Link Address' as it is the address which is being copied not the
location.

I realise this is a ridiculously small bug but i feel it would be beneficial
nevertheless.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
I would tend to agree with the reporter on this point. Many a time have I
wondered to myself why exactly we have this weird wording.

--> Menus
Component: General → Menus
OS: Windows XP → All
QA Contact: bugzilla
Hardware: PC → All

Updated

14 years ago
Severity: trivial → enhancement

Updated

14 years ago
Flags: blocking1.0?
Keywords: polish

Updated

14 years ago
Blocks: 214267

Comment 2

14 years ago
I thought it was just a throwback to The Beginning of Time (tm) as URL's have
always been referred to as "Addresses" by IE and "Locations" by Netscape (since,
version 4?). Well, there was that "Netsite" label for awhile.

But in general, I just think it's a vocabulary difference from the browser wars.
"Address" has become the preferred consumer-friendly term because IE won.

Comment 3

14 years ago
Wontfixing as per bug 203720. It appears that we've chosen location.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking1.0?
Resolution: --- → WONTFIX
(Reporter)

Comment 4

14 years ago
I think you're making a mistake, can I urge you to reconsider ?  You said
yourself 'I wondered to myself why exactly we have this weird wording.'.

Comment 5

14 years ago
Okay, we can reopen this, and Ben will look at it as part of his Awkward UI Text
review. Although I think that this decision as already been made...
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Updated

14 years ago
Flags: blocking1.0?
(Assignee)

Updated

14 years ago
Flags: blocking1.0? → blocking1.0-

Updated

14 years ago
No longer blocks: 214267

Updated

14 years ago
Blocks: 214267
I vote WONTFIX. Since it's called the "Location bar", it should also say "Copy
Link Location".
(Reporter)

Comment 7

14 years ago
We are trying to make Firefox appropriate for IE 'switchers', end users _are_
going to be confused by the current wording.

Comment 8

14 years ago
Created attachment 156114 [details] [diff] [review]
Location changed to Address for "Copy [Link|Image] Location"
Assignee: firefox → jwalden+bmo
Status: REOPENED → ASSIGNED

Comment 9

14 years ago
Created attachment 156115 [details] [diff] [review]
Change wording, update Help

Oops, should have updated Help docs for the change (this patch fixes this). 
Sorry for the bugspam.
Attachment #156114 - Attachment is obsolete: true

Comment 10

14 years ago
Comment on attachment 156115 [details] [diff] [review]
Change wording, update Help

Requesting review from blake...a simple patch, just decide if you think it
should be done.
Attachment #156115 - Flags: review?(firefox)

Comment 11

14 years ago
This is a localization change, so *if* it should be made then it needs to be
made before 1.0 PR.  The tracker's been minused, so setting the flag to ? is the
proper move, I believe.

-->blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR?

Updated

14 years ago
Summary: 'copy link location' should say 'copy link address' → 'copy [link|image] location' should say 'copy [link|image] address'

Updated

14 years ago
Whiteboard: [have patch]

Comment 12

14 years ago
blake, can you review?
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR+
Comment on attachment 156115 [details] [diff] [review]
Change wording, update Help

You can't change the terminology in one place without changing it everywhere.
Attachment #156115 - Flags: review?(firefox) → review-

Comment 14

14 years ago
Created attachment 156648 [details] [diff] [review]
Better patch, verified against grep -iRl 'copy [image|link] location' *

Updated

14 years ago
Attachment #156115 - Attachment is obsolete: true

Updated

14 years ago
Attachment #156648 - Flags: review?(bugs)

Updated

14 years ago
Whiteboard: [have patch] → [have patch] - need review ben
The patch here still does not address the fact that this is a terminology
mismatch with the rest of the application. We use "Location" to refer to the
location of documents (html pages, images, etc) throughout the application, and
applying piecemeal patches is not the way to make changes. I'm not necessarily
convinced of the benefit of Address vs. Location anyway. I'm minusing this bug. 
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR-

Updated

14 years ago
Attachment #156648 - Flags: review?(bugs)

Comment 16

14 years ago
If Ben isn't sure that this is a good idea, I'll defer to him.  The benefit *is*
rather dubious, and we'd probably also have to change it to the Address Bar
(which seems like something that wouldn't be done) if this were to be properly
fixed as Ben describes.

I've given it a shot, been turned down, and I realize this isn't something that
likely matters much.  Someone else can take this.
Assignee: jwalden+bmo → firefox
Status: ASSIGNED → NEW
Based on comments from Ben and Jeff, marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 18

13 years ago
I'm going to make one last plea, I have several times heard people wonder what
is mean by 'location'.  If it requires lots of changes that should not be a
barrier, I think this is a good change to make.

Comment 19

13 years ago
Az: If you file a new bug asking for a terminology change (location -> address)
throughout Firefox, I'll vote for it.
(Reporter)

Comment 20

13 years ago
Please see bug 289458

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.