Closed Bug 241684 Opened 17 years ago Closed 17 years ago

save as download corrupt

Categories

(Toolkit :: Downloads API, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 235859

People

(Reporter: orbplus2000, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040425 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040425 Firefox/0.8.0+

When I try to save as download from the Mozilla ftp site, I end up with
downloaded files that are corrupt.  When I use Mozilla the files are OK, but
Firefox has corrupted downloads for at least the past several months.  I tried
creating a new profile and it still keeps happening.

Reproducible: Always
Steps to Reproduce:
1.Go to http://ftp.mozilla.org 
2.Download a Thunderbird nightly build for Mac OS X
3.

Actual Results:  
File is corrupted.

Expected Results:  
The same file works fine if downloaded in Mozilla.

I was using the default theme on Firefox.  I am running Mac OS 10.3.3
Can you be a little more specific as to what errors you're getting? Is the
downloaded filesize actually correct? Is the downloaded file too large or too
small? Are you using any downloading-related extensions?
What happens is that Stuffit Expander says some file info is missing and asks if
you want to try anyway to expand it.  If I choose Try it immediately displays
the same error again.  If I choose Don't Try it gives up and nothing happens. 
The exact same files download fine on Mozilla SeaMonkey.  I have encountered
this problem since the new download manager has been used in Firefox.  I am
doing the download by browsing to the file (in this case the file was today's
Mac nightly of Thunderbird, which was a build that expands correctly if
downloaded with SeaMonkey) and holding the mouse down and choosing the Save as
option.  The file appears to download correctly.

My guess is that either part of the file is cut off or the resource fork or
permissions are either corrupted or missing.
Can you compare the filesize on the ftp.mozilla.org server and the file you
download and report back if the two are the same or different?

Can we assume you're downloading this?
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/thunderbird-mac-MachO.dmg.gz
The good file is 11,053,352 bytes.  The bad file is 32,928,259 bytes.  Both are
supposed to be 10.5 MB but the bad one is way too big.  This is the latest trunk
build for Mac OS X.
Okay, that's helpful, now I know what's going on. This bug is a dupe of bug
235859 where the file is silently uncompressed without the user asking for it to
happen. If you rename the file from *.dmg.gz to *.dmg you'll notice that it
should be a valid .dmg file. Marking as a dupe.

*** This bug has been marked as a duplicate of 235859 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.