hsp.dynu.com - getelementbyid returning undef when trying to select div, h1 (maybe other) tags within select statements

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
3 years ago

People

(Reporter: sendmespam, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Debian/1.6-5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Debian/1.6-5

document.getElementById('someid') doesn't work for elements within <select>
statements (see debug output d1-d7 on supplied url).


Reproducible: Always
Steps to Reproduce:
1. use div, h1 (maybe others) within a select
2. try to getElementById one of those id'd items
3. see the complaints on the console (xxx has no properties)



Expected Results:  
give access to the div/h1/etc. elements.
Script tags in the body do not necessarily execute after the document has loaded
-- you want the onload event handler for the body tag, that's what it is for
(and has been since 1995).

Don't misfile JS engine bugs like this again.

/be
Assignee: general → nobody
Component: JavaScript Engine → English US
Product: Browser → Tech Evangelism
Version: Trunk → unspecified

Updated

14 years ago
Assignee: nobody → english-us
QA Contact: pschwartau → english-us
Summary: getelementbyid returning undef when trying to select div, h1 (maybe other) tags within select statements → hsp.dynu.com - getelementbyid returning undef when trying to select div, h1 (maybe other) tags within select statements

Comment 2

10 years ago
It's pretty clear what the problem is from comment 1, but that doesn't make this a valid TE bug. Bugzilla is not a tech support forum, etc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.