Image with multipart/x-mixed-replace doesn't keep updating

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Joseph Becher, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040412 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040412 Firefox/0.8.0+

When viewing the above url the image does not update correctly. According to
http://tycho.usno.navy.mil/howclock.html that is because it is not handling the
'multipart/x-mixed-replace' content type correctly.

Reproducible: Sometimes
Steps to Reproduce:
1. Visit http://tycho.usno.navy.mil/howclock.html or one of the clocks on
http://tycho.usno.navy.mil/what1.html
2. Wait fot them to update.
3.

Actual Results:  
Somtimes they work, mostly they work for a brief time then quit, or don't update
at all.

Comment 1

14 years ago
WFM.  It updates for several seconds and then stops, just like in Netscape 4.
Summary: Content-type: multipart/x-mixed-replace Is not handled correctly → Image with multipart/x-mixed-replace doesn't keep updating

Comment 2

14 years ago
This is not a bug in Mozilla (or Firefox): if you try to wget a clock image, the
server sends images for a few seconds (separated by "--DELIMIT\n"), and then
sends a multipart end boundary ("--DELIMIT--\n") and closes the connection with
the client.

So the browsers are doing the right thing: they keep displaying new images as
long as the server sends them.
This bug was last touched before 1.0.4. Is it still reproducable?
Try the latest branch build (1.0.5): http://www.mozilla.org/products/firefox/
Try the latest nightly trunk build (v1.0+): http://www.mozilla.org/developer
(Reviving old UNCONFs)

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060218 Firefox/1.6a1

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.