Core dump if java1.3 plug-in is put in plugins directory

RESOLVED INCOMPLETE

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INCOMPLETE
14 years ago
8 years ago

People

(Reporter: John Cloudman, Assigned: Alfred Peng)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.7b) Gecko/20040424
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.7b) Gecko/20040424

When I try to load mozilla 1.7, if I have the Java 1.3 plugin (distributed by
HP) linked into the mozilla plugins directory, mozilla core dumps.  This did not
happen in mozilla 1.6.  I'll put the error message in the "Actual Results" section.

Reproducible: Always
Steps to Reproduce:
1. Install the HP Java 1.3 JRE and Plug-in from www.hp.com/go/java.
   Product: Jre13  version: 1.3.1.13.01  description:  Java2 1.3 RTE 1.3
   Product: Jpi13  version: 1.3.1.13.01  description:  Java2 1.3 Netscape Plugin

2. Copy (or link) libjavaplugin_oji.sl from
/opt/java1.3/jre/plugin/PA_RISC/ns600/libjavaplugin_oji.sl into /opt/mozilla/plugins

3. Run /opt/mozilla/mozilla
Actual Results:  
aCC runtime: Error 215 from
shl_findsym(/opt/java1.3/jre/plugin/PA_RISC/ns600/libjavaplugin_oji.sl,_shlInit)
/usr/lib/dld.sl: Unresolved symbol: 
[Vftptr]key:__cl__16nsQueryInterfaceCFRC4nsIDPPv (data)  from
/opt/java1.3/jre/plugin/PA_RISC/ns600/libjavaplugin_oji.sl
/opt/mozilla/run-mozilla.sh[36]: 11784 Abort(coredump)


Expected Results:  
Started Mozilla normally.

Updated

14 years ago
Assignee: peterlubczynski-bugs → kyle.yuan
Component: Plug-ins → Java: OJI

Comment 1

14 years ago
I don't know antthing about JRE on HP-UX, but I have two question:

1) On Solaris (or Linux), you should *link* (not copy) libjavaplugin_oji library
to mozilla's plugin directory. And also the directory you should link from is
ns610 (jre1.4.x) or ns7 (jre 1.5), not ns600.

2) Is there any higher version jre available for HP-UX? If so, please use that
one and try again. jre 1.3 is quite old for mozilla 1.7.

Updated

13 years ago
Assignee: yuanyi21 → pete.zha

Comment 2

13 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng
no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.