Installer needs -lnsl on Solaris

VERIFIED DUPLICATE of bug 260337

Status

()

Firefox
Installer
VERIFIED DUPLICATE of bug 260337
14 years ago
12 years ago

People

(Reporter: Iain MacDonnell, Assigned: Andrew Schultz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040424 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040424 Firefox/0.8.0+


gmake[5]: Entering directory
`/export/stuff/mozilla/ff-branch/mozilla/toolkit/mozapps/installer/unix/wizard'
CC -xO2 -xchip=ultra -xprefetch -dalign -fns -fsimple=1 -features=tmplife -o
mozilla-installer-bin  -xbuiltin=%all -mt  -DNDEBUG -DTRIMMED -xO4
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include    nsINIParser.o nsXInstallerDlg.o nsComponent.o
nsSetupType.o nsComponentList.o nsRunApp.o nsLicenseDlg.o nsWelcomeDlg.o
nsSetupTypeDlg.o nsComponentsDlg.o nsInstallDlg.o nsZipExtractor.o nsXIOptions.o
nsXIContext.o nsXInstaller.o nsXIEngine.o  -xildoff -zlazyload -zcombreloc   
-L../../../../../dist/bin -L../../../../../dist/lib -lgtk-x11-2.0 -lgdk-x11-2.0
-latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangox-1.0 -lpango-1.0 -lgobject-2.0
-lgmodule-2.0 -ldl -lglib-2.0   ../../../../../dist/lib/libjar50_s.a
../../../../../dist/lib/libxpnet_s.a -lpthread  -lsocket -ldl -lm
CC: Warning: -xO4 overwrites previously set optimization level of -O2
Undefined                       first referenced
 symbol                             in file
gethostbyaddr                      
../../../../../dist/lib/libxpnet_s.a(nsSocket.o)  (symbol belongs to implicit
dependency /usr/lib/libnsl.so.1)
gethostbyname                      
../../../../../dist/lib/libxpnet_s.a(nsSocket.o)  (symbol belongs to implicit
dependency /usr/lib/libnsl.so.1)
inet_addr                          
../../../../../dist/lib/libxpnet_s.a(nsSocket.o)  (symbol belongs to implicit
dependency /usr/lib/libnsl.so.1)
ld: fatal: Symbol referencing errors. No output written to mozilla-installer-bin
gmake[5]: *** [mozilla-installer-bin] Error 1


This is building firefox from the 1.7 branch. Not sure if it's firefox-
specific, so reporting it against browser as the lowest possible common-
denominator.


Reproducible: Always
Steps to Reproduce:
1. Try to build with --disable-installer on Solaris / SunStudio
2.
3.

Actual Results:  

Build fails.

Expected Results:  

Build should work.
(Reporter)

Comment 1

14 years ago
Erm, in the "Steps to reproduce", I, of course, meant to say "build withOUT
--disable-installer"
(Assignee)

Comment 2

14 years ago
Are you building on Sun hardware or x86 (might not matter)?

Installer got forked

==> firefox
Assignee: general → bryner
Component: Installer → Installer
OS: other → Solaris
Product: Browser → Firefox
QA Contact: bugzilla → bugzilla
Version: Trunk → unspecified
(Reporter)

Comment 3

14 years ago
I'm building on SPARC in this case, but I'm pretty sure it'd be the same on
Solaris/x86.
(Assignee)

Updated

14 years ago
Hardware: Other → Sun
This may be the same problem as in bug 209747 and bug 237692
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> This may be the same problem as in bug 209747 and bug 237692

Not really - I don't believe this one has anything to do with GTK2. Note 100%
sure, though.


Comment 6

13 years ago
This is fixed in #260337.

https://bugzilla.mozilla.org/attachment.cgi?id=159696&action=view
(Assignee)

Comment 7

13 years ago
Created attachment 162383 [details] [diff] [review]
direct port from aviary

see bug 260337
Assignee: bryner → ajschult
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Comment 8

13 years ago
ugh.  is this not needed for the Seamonkey installer?  I can't find a reason why
it wouldn't be needed, but no bugs were ever filed.

resolving as dupe of bug 260337

*** This bug has been marked as a duplicate of 260337 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.