Closed Bug 241813 Opened 17 years ago Closed 17 years ago

Loading Tab with HTML Form steals focus from another tab.

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: jeremyedwards, Unassigned)

References

()

Details

(Whiteboard: DUPEME)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

Going to a web page with an HTML form steals focus from a "newer" tab when it
fully loads.

This bug is noticed by power tab users. Also, it works best on pages that have
login forms like http://mail.yahoo.com

Reproducible: Always
Steps to Reproduce:
You must perform this fast.
1. Go to a web site with a login form, http://mail.yahoo.com works best for me.
2. Before the page fully loads, create a new tab and start writing something in
the address bar.
3. After the Yahoo Mail page fully loads the login form will steal text input
focus from the browser, as you can see from changing back to that tab.
Actual Results:  
Yahoo Mail web page's (background tab) login form (username) steals focus from
active tab.

Expected Results:  
The focus should still be kept on the front (active) tab. Not be stolen from a
tab from the background.
Already filed.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.