javascript equivalent of usercontent.css

RESOLVED DUPLICATE of bug 89016

Status

()

Core
DOM
--
trivial
RESOLVED DUPLICATE of bug 89016
14 years ago
14 years ago

People

(Reporter: Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com], Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Would it be possible to have a javascript file that gets run on every page load?

I put together a quick hack, which involved putting
body
{ -moz-binding: url("chrome://userjstest/content/test.xml#obj"); } 

in my userContent.css, and creating a XML file with some JS in the constructor.

It works... sort of.  For one thing, autoscroll doesn't work well with it.  The
other problem is that I can't get the code to run *after* the page loads (or
even automatically at all - I have to trigger it with something like an
onmouseover).
Assignee: general → general
Component: JavaScript Engine → DOM
QA Contact: pschwartau → ian

Updated

14 years ago
Summary: javascript equivalent of usercontent.js → javascript equivalent of usercontent.css

Comment 1

14 years ago
Duplicate of bug 89016?
Yes.

*** This bug has been marked as a duplicate of 89016 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.