If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Audiotrak - javascript menus not showing when on link click

RESOLVED INCOMPLETE

Status

Tech Evangelism Graveyard
English US
RESOLVED INCOMPLETE
14 years ago
3 years ago

People

(Reporter: Apostolos Dimitromanolakis, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Not much more to say. I have no idea why this occurs. Just try to click on any
link. According to javascript a menu should appear but it doesn't which makes
the page useless.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
JS console shows errors for these, for example for the first link:

Error: pd71d01 is not defined
Source File: javascript:content(pd71d01);
Line: 1

I guess this implies a fault in the page -> TE ?

Comment 2

14 years ago
function content(num){
	var num
	if ( num.style.display == "none" ) 
		   num.style.display = "";
    else num.style.display = "none";
	}

<A href="javascript:content(pd71d01);"><font size="+1">[PRODIGY 7.1]</font></A>

-> Evangelism
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → english-us
Summary: javascript menus not showing when on link click → Audiotrak - javascript menus not showing when on link click
Version: Trunk → unspecified

Comment 3

14 years ago
Changing the beginning of the function to:

   function content(num_id){
     var num = document.getElementById(num_id);
     if [...]

and the function calls to:

   <a href="javascript:content('pd71d01');"> 

makes this work in Mozilla AND IE/Opera.
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

7 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 5

7 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.