Drag-n-drop link to download manager doesn't work

RESOLVED FIXED

Status

()

Toolkit
Downloads API
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: KF Leong, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0, regression})

unspecified
fixed-aviary1.0, regression
Points:
---
Bug Flags:
blocking1.7 -
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040426 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040426 Firefox/0.8.0+

When trying to download file thru an HTML link using drag-n-drop to the Download
Manager does not work. The process starts but nothing happens. No file is
downloaded & the manager 

Reproducible: Always
Steps to Reproduce:
1. Open download manager, i.e. Ctrl-Y.
2. Drag link to download manager.
3. Asks where to put file dialog appears and click OK.
4. Starting... Starting... Nothing happens!

Actual Results:  
Download manager shows the request but the download is not working.

Expected Results:  
Download should start & finish!

Comment 1

14 years ago
I think this might be another thing broken by the checkin that made downloads
send the referrer url, though I can't remember what the other bug was now. :-(

Comment 2

14 years ago
Found it now, Bug 239472, same cause, different effect, making the change I
suggested in that bug also fixes this one.

CONFIRMING
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

14 years ago
Depends on: 239472

Updated

14 years ago
Flags: blocking1.0?
Flags: blocking0.9?

Comment 3

14 years ago
While it would be nice to have this fixed by 0.9, it's not essential that we fix
this before 0.9 ships. Most people will never hit this bug.
Flags: blocking0.9? → blocking0.9-
OS: Windows XP → All
Hardware: PC → All

Comment 4

14 years ago
Created attachment 148101 [details] [diff] [review]
Simple Fix: Add some if()s

This fixes the problem by adding a couple of if() statements, we can't assume
that there even will be a content frame so check first (there won't be if the
dl originates directly in the DM or in the Page Info dialog, see Bug 239472). I
don't know whether it would be more appropriate to try guessing the referrer
from the top browser window in cases such as this but I didn't bother adding
anything along those lines.
+ing since there's a patch
Flags: blocking1.0? → blocking1.0+
Fix checked in branch and trunk. 

r=ben@mozilla.org
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.