Powerpoint configured as a Helper Application reacts differently if PPT file on same server or other server

RESOLVED EXPIRED

Status

SeaMonkey
General
RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: Rob Schneider, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Have Powerpoint 2003 configured correctly in Mozilla 1.6.   mimetype:
application/vnd.ms-powerpoint, Description: Microsoft PowerPoint
Extension: ppt, (Selected)Open it using default application
See example page.  Clicking on the Case Study 1, the PPT file is located on
another web site. No matter how Helper Application conifigured, it loads the
binary file as text.  Clicking on the Case Study 2, the PPT file is correctly
downloaded and PowerPoint is launched.  Here the PPT file is on the same server
as the page in which the link is.  Note:  the link is set to load into a new
window for both these files.

Cannot reproduce this when using Adobe file or Word file.  See example ADobe
file loaded from the other server. It works ok.

Reproducible: Always
Steps to Reproduce:
1.  on my machine
2.  on a collegues machine using Mozilla on XP
3.  not able to try on any other OS

Actual Results:  
As explained in details.  Behaviour of loading this PowerPoint file differed
depending on what server the PPT is located.

Expected Results:  
When loading the PPT file from the other server, it should have respected the
application helper configuration and downloaded and loaded into Powerpoint.

Comment 1

14 years ago
It looks like both case studies are on the same server and both would load if I
had a app to load them in.  If they where on diffrent servers my first guess is
that the second server was sending the file as text/plain which according to
some spec is to be displayed as plain text.
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.