images cause list to be rendered incorrectly

RESOLVED DUPLICATE of bug 163110

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 163110
14 years ago
13 years ago

People

(Reporter: Tom Schneider, Unassigned)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031016
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031016

The bug appears in lists with right aligned images. Each new item in the list is
more and more restricted to the left side of the page. This cannot be fixed by:

<br clear=all>


Reproducible: Always
Steps to Reproduce:
1. create a list like this:

<ul>
<li> <img src = "myimage.jpg" align = right>
<li> <img src = "myimage.jpg" align = right>
<li> <img src = "myimage.jpg" align = right>
<li> <img src = "myimage.jpg" align = right>
<li> <img src = "myimage.jpg" align = right>
</ul>
2. put images in front of the <li> for each item as shown above
3. have many items with images in the list

Actual Results:  
After each item the page width becomes more and more restricted, eventually
to the point of only one word per line.


Expected Results:  
Each part of the list should render separately, there should not be carry over
from one to the next.

This has been a problem for a while.  I think I've reported it before
more than a year ago.  It's time to fix it!  Though I don't have the latest
version of Mozilla, I just downloaded Firefox 0.8 and that also has the bug.
Netscape 4 did not have the bug.  This is one of the last bugs that prevents
me from abandoning Netscape entirely.

*** This bug has been marked as a duplicate of 163110 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
OS: SunOS → Solaris
Product: Browser → Seamonkey
(Reporter)

Updated

13 years ago
Severity: normal → blocker
Severity: blocker → normal
You need to log in before you can comment on or make changes to this bug.