99% cpu utilization on reply in LiveJournal

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
--
critical
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: jcollins, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040418 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040418 Firefox/0.8.0+

Frequently when attempting to reply to LiveJournal entries, the browser will
hang and processor utilization will climb to 99%.  The rest of the system is
responsive, it's just Firefox that hangs.  The only way to exit the browser at
this point that I've found is to send it a SIGTERM request.

Reproducible: Sometimes
Steps to Reproduce:
Currently any attempt to load the referenced URL causes the problem, but
retrieving the URL (via wget) and loading it locally does not cause the same
problem.

Actual Results:  
99% processor utilization

Expected Results:  
Loaded the page and allowed the response to be submitted with minimal processor
usage.
(Reporter)

Comment 1

14 years ago
Created attachment 147187 [details]
strace of the browser attempting to access the referenced URL

Comment 2

14 years ago
I'm getting this today since upgrading to 0.9 on Win2K.  I'll create a new bug
and link to this.

Comment 3

14 years ago
I am also experiencing this since upgrading to the 0.9 milestone on XP:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Nevermind the UA string that wasn't updated for 0.9...

Comment 4

14 years ago
Works for me, using Window XP's Task Manager. Firefox usage stayed at 00.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040619
Firefox/0.9.0+

Comment 5

14 years ago
see also bug 247504

Comment 6

14 years ago
*** Bug 247504 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
I've reopened 247054.

Comment 8

14 years ago
I am on Gentoo, Firefox 0.9.1.  Built using emerge mozilla-firefox.

USE flags include: GTK2 Gnome.
No similar problems with Opera.

Similar results as documented previously.

Comment 9

14 years ago
To clarify, there seem to be many ways to this bug.  Here is one way.

1) Log in to livejournal as a user, and set it so that you are always logged in,
via some cookie, I assume.
2) Close the browser.
3) Go to someone else's page, already logged in.
4) Post a comment in someone else's journal.  (Or reply)

Here is a fuller description of my UA.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040718 Firefox/0.9.2

Comment 10

14 years ago
Created attachment 153605 [details]
A snippet of the saved passwords file, which when removed, seems to fix the problem.

A suitably (I hope) censored version of the entry that I believe was causing
the problem.

Comment 11

14 years ago
So, it appears I could not view passwords in my firefox either.

It seems a workaround for this bug might be to go in and delete the livejournal
saved passwords information.  It appears to work for me.  That file is located in:

$HOME/.mozilla/firefox/default.26x/<somenumber>.s

It is editable with emacs/nano, and one can find the parts that need to be deleted.

It appears whatever converted the saved passwords over to 0.9.x broke something
about this file.  The attachment is available for inspection, for those who
might want to track down the root cause of this bug.

For now, it appears removing the livejournal.com entry, or the whole file, will
do the trick for fixing the browser.

Comment 12

14 years ago
I can confirm this works for me on 0.9 0626 nightly win2k:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.8 
(Reporter)

Comment 13

14 years ago
Removing LiveJournal's passwords manually does indeed appear to have corrected
the problem.

I think there have been enough entries on this report that it deserves to move
out of the UNCONFIRMED category.  I know I've been fighting with it daily for
over a month now.
*** Bug 247504 has been marked as a duplicate of this bug. ***
confirming based on dupe
Assignee: firefox → bryner
Status: UNCONFIRMED → NEW
Component: General → Password Manager
Ever confirmed: true
QA Contact: davidpjames
*** Bug 251200 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
Happens on OSX also.  Everytime I try to leave a comment in someones
livejournal.  Firefox hangs and needs to be restarted.  I can view comments just
fine though.
With console running, this is the last message I get before I need to restart
firefox.

2004-09-05 08:42:54.414 loginwindow[372] Could not find image named `bang'.
Sep  5 09:01:54 Europa /Applications/Firefox.app/Contents/MacOS/firefox-bin: ***
Warning: ATSUMeasureText has been deprecated.  Use ATSUGetUnjustifiedBounds
instead. ***

Comment 18

13 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050526
Firefox/1.0+

Does anyone still experience this bug?

Comment 19

12 years ago
Mass edit: Changing QA to default QA Contact
QA Contact: davidpjames → password.manager
Assignee: bryner → nobody
Version: unspecified → Trunk

Comment 20

12 years ago
(In reply to comment #18)
> WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050526
> Firefox/1.0+
> 
> Does anyone still experience this bug?

I do still experience this bug, with Firefox versions up to and including 1.5.0.6, (haven't yet seen it on 1.5.0.7 - it's pretty intermittent)

It should be noted I have never tried editing my passwords file as suggested in the comments. However, I'm running on a computer that's only 17 months old, I initially installed version 1.0 (at least) on this machine. Whatever corruption is presumably happening to the password file must not be limited to the 0.9 transition.
The strace seems to indicate that the hang is cause by a giant read of repeated 0xC382 characters. Hard to tell what would have caused that. Given that the password file format has changed since 1.5, and the password manager has undergone significant changes, it seems unlikely that this is reproducible on FF2.

If someone can provide steps to reproduce on FF2+, please repoen.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.