Closed Bug 241964 Opened 16 years ago Closed 16 years ago

Sort by Multiple Columns

Categories

(MailNews Core :: Filters, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 57898

People

(Reporter: mvolikas, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040426
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040426

Sorting by a single column in Mozilla Mail is a simple matter of clicking on the
column head. However, it would be nicer if I could sort on multiple columns.

For ex., sort by the first criterion, such as From, by clicking on the column
head. Then hold the Shift key down as you click on a second heading, such as
Received. Your messages will be sorted primarily by sender, and all the messages
from each sender will be ordered chronologically. If you add additional columns
to sort by, Mozilla Mail should sort your messages by each additional criterion
within the earlier criteria to give you a multicolumn sort.

Reproducible: Always
Steps to Reproduce:
1. Sort by the first criterion, such as From, by clicking on the column head
2. Hold the Shift key down as you click on a second heading, such as Received.


Actual Results:  
Messages are resorted using the second column criteria

Expected Results:  
Your messages should be sorted primarily by sender, and all the messages from
each sender should be ordered chronologically.

*** This bug has been marked as a duplicate of 57898 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.