mail window freezes as soon as an email with a .ppt or .xls attachment is selected

RESOLVED DUPLICATE of bug 237947

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED DUPLICATE of bug 237947
14 years ago
13 years ago

People

(Reporter: Scott Packard, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7b) Gecko/20040319
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7b) Gecko/20040319

CPU pegs and app. needs to be killed when selecting an incoming
email with a .ppt or a .xls attachment.  (Perhaps other MS created files do it
also?)

I tried sending myself a text attachment as an email.  It came in and I could
view it and save it fine.  I tried an .sxw attachment (StarOffice6/7 text
document).  That worked fine too.
The Content-Type for the StarOffice file showed:
Content-Type: multipart/mixed; boundary="------------010607080103040305010003"

When I tried to send myself a .xls attachment email The Compose window
hung right after I depressed the "Send" button.  The Send button
still looked depressed, (as am I).


Reproducible: Always
Steps to Reproduce:
See Details above.




Perhaps it's a particular content-type problem?

I used less to look at my Inbox.  The Excel attachment and PowerPoint
attachment came in as the lines below:

Content-Type: application/octet-stream;
        name="NIS_UserName_List1.xls"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
        filename="NIS_UserName_List1.xls"


Content-Type: application/vnd.ms-powerpoint;
        name="WindRiver.ppt"
Content-Transfer-Encoding: base64
Content-Description: WindRiver.ppt
Content-Disposition: attachment;
        filename="WindRiver.ppt"


in my mimeTypes.rdf file:
...
  <RDF:Description RDF:about="urn:mimetype:application/vnd.ms-excel"
                   NC:value="application/vnd.ms-excel"
                   NC:editable="true"
                   NC:description="">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:application/vnd.ms-excel"/>
    <NC:fileExtensions>xls</NC:fileExtensions>
    <NC:fileExtensions>xlt</NC:fileExtensions>
    <NC:fileExtensions>xlm</NC:fileExtensions>
    <NC:fileExtensions>xld</NC:fileExtensions>
    <NC:fileExtensions>xla</NC:fileExtensions>
    <NC:fileExtensions>xlc</NC:fileExtensions>
    <NC:fileExtensions>xlw</NC:fileExtensions>
    <NC:fileExtensions>xll</NC:fileExtensions>
  </RDF:Description>
...
  <RDF:Description RDF:about="urn:mimetype:application/vnd.ms-powerpoint"
                   NC:value="application/vnd.ms-powerpoint"
                   NC:editable="true"
                   NC:description="Microsoft PowerPoint Show">
    <NC:fileExtensions>ppt</NC:fileExtensions>
    <NC:fileExtensions>pot</NC:fileExtensions>
    <NC:fileExtensions>ppa</NC:fileExtensions>
    <NC:fileExtensions>pps</NC:fileExtensions>
    <NC:fileExtensions>pwz</NC:fileExtensions>
    <NC:handlerProp
RDF:resource="urn:mimetype:handler:application/vnd.ms-powerpoint"/>
  </RDF:Description>

Comment 1

14 years ago
Likely dup of bug 237947
Does this happens with current builds?
(Reporter)

Comment 2

14 years ago
Let me close it and mark it as a duplicate of the bug you suggested.
I'll try either a nightly build or a more recent build than 1.7b.
For the problem I described I had gone to the website and grabbed 
what I thought was the Mozilla 1.7 RC1 release.  As reported in this
bug I see whatever version I'm running identifies itself as 1.7b
so now I'm not positive I have 1.7RC1.  Even then, I'll look at the
other bug to see if that will solve the problem.


Just as an aside, I sure wish I could use bugzilla to do an effective search
for these bugs before I open one.  I tried reviewing bugs for about a half
hour before filing this new one.  It takes you only 3 minutes to find a 
suspected duplicate.  Clearly I haven't used the search effectively.

*** This bug has been marked as a duplicate of 237947 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
OS: SunOS → Solaris
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.