Support for NOTIFY parameter of the ESMTP RCPT command (RFC 3461)

RESOLVED DUPLICATE of bug 93085

Status

MailNews Core
Networking: SMTP
--
enhancement
RESOLVED DUPLICATE of bug 93085
14 years ago
10 years ago

People

(Reporter: Angelo, Assigned: Scott MacGregor)

Tracking

({helpwanted})

Trunk
helpwanted
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.6) Gecko/20040206 Firefox/0.8

Will be really useful and is a standard from the IETF.
If supported, using that there will be a method to know if the e-mail sent was
successfully processed, has been delayed or has failed.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

14 years ago
OS: Windows XP → All
(Reporter)

Updated

14 years ago
Hardware: PC → All
(Reporter)

Updated

14 years ago
Component: Message Compose Window → General

Updated

14 years ago
Severity: normal → enhancement
Component: General → Networking: SMTP
Product: Thunderbird → MailNews
Version: unspecified → Trunk
Product: MailNews → Core
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
This enhancement would give us the ability to request Delivery Status
Notifications (DSN), known to Outlook users as "delivery receipts".

Before NOTIFY parameter can be used:
1. SMTP server must support ESMTP and DSNs for this to work.
2. Mozilla must EHLO to activate ESMTP extensions on the server.
    a) ...and check for "DSN" as a supported extension.

Considerations:
1. Should there be some notification to the user through the UI if the user's
   SMTP server doesn't support ESMTP or DSN?  Arguably a separate RFE.
2. Documentation in Help about this feature should point out that a DSN may
   not be forthcoming if a server doesn't support the feature.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
(Assignee)

Comment 2

13 years ago
not a 1.1 stopper
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Keywords: helpwanted

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 93085 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.