Some Big5 Chinese symbols are not rendered properly

RESOLVED WORKSFORME

Status

()

Core
Internationalization
--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: stephen@ju-ju.com, Assigned: smontagu)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421

When displaying BIG5 Chinese pages, the characters immediately follow the symbol
BIG-5 0xA14B are not rendered properly

Reproducible: Always
Steps to Reproduce:
1. Create a BIG-5 encoded HTML file
2. Type some text with symbol 0xA14B in the middle of the text
3. Open the file in Mozilla

Actual Results:  
The characters after the symbol 0xA14B are all messed up. Almost none of the
gets rendered.

Expected Results:  
Properly displayed Chinese text.
(Reporter)

Comment 1

14 years ago
Created attachment 147306 [details]
Sample to show the bug
(Assignee)

Comment 2

14 years ago
It would be helpful if you could provide a screenshot of the actual and expected
rendering.
Assignee: nobody → smontagu
Component: Layout: Fonts and Text → Internationalization
QA Contact: core.layout.fonts-and-text → amyy
(Reporter)

Comment 3

14 years ago
Created attachment 147335 [details]
Screenshot of sample rendered in Mozilla
(Reporter)

Comment 4

14 years ago
Created attachment 147336 [details]
Screenshot of sample rendered in Safari
(Reporter)

Comment 5

14 years ago
Uploaded screenshots of the same sample file. Note Safari is configured to use a
different font but it doesn't matter which font I use in either of the browsers.

BTW. The OS is OS X 10.3.3.

Comment 6

14 years ago
WFM using Mozilla-Mac/2004042110 on OS X 10.2.8. Reassigning to Layout: Fonts
and Text.
Assignee: smontagu → nobody
Component: Internationalization → Layout: Fonts and Text
Keywords: intl
QA Contact: amyy → core.layout.fonts-and-text
Summary: Some BIG-5 Chinese symbols are not rendered properly → Some Big5 Chinese symbols are not rendered properly
Considering smontagu moved this to i18n and it seems like it could be a decoder
problem, moving *back* to i18n.
Assignee: nobody → smontagu
Component: Layout: Fonts and Text → Internationalization
QA Contact: core.layout.fonts-and-text → amyy

Comment 8

14 years ago
I've just reproduced this bug on Mac (with 1.6). At first I thought this bug is
due to that Safari's interpretation of Big5 is different from that of Mozilla,
but it turned out that Mozilla on Linux render the sample case (attachment
147036 [details]) exactly the same way as Safari does, which means that it can't be a
decoder issue
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

12 years ago
This problem is still in the latest build of Firefox 2.0.

It only occurs in Mac version, not Windows. I also find the same text encoded in UTF-8 doesn't show the problem.
(Reporter)

Comment 10

11 years ago
The problem is no longer reproducible in trunk. I think the new GFX implementation fixed it?

Comment 11

11 years ago
Confirmed, I just downloaded a trunk build and can't reproduce this any more.
(Assignee)

Comment 12

11 years ago
WORKSFORME per last comments
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.