Last Comment Bug 242123 - remote option parsing broken
: remote option parsing broken
Status: RESOLVED FIXED
: fixed-aviary1.0
Product: Core
Classification: Components
Component: X-remote (show other bugs)
: Trunk
: x86 Linux
: -- major (vote)
: ---
Assigned To: Christopher Blizzard (:blizzard)
: Christopher Blizzard (:blizzard)
:
Mentors:
: 229681 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 14:45 PDT by Karsten Bräckelmann
Modified: 2006-03-12 17:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (861 bytes, patch)
2004-05-04 19:59 PDT, Christopher Blizzard (:blizzard)
darin.moz: review+
bryner: superreview+
mozilla: approval1.7.5+
Details | Diff | Splinter Review

Description Karsten Bräckelmann 2004-04-29 14:45:21 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421

The remote option as described in http://www.mozilla.org/unix/remote.html is
broken in 1.7rc1. As the document mentions, a space after the "," should work --
and actually it did at least until 1.6.

Reproducible: Always
Steps to Reproduce:
This one fails:
 $ mozilla -remote 'openURL('http://mozilla.org', new-tab)'
 Error: Failed to send command: 509 internal error

This works:
 $ mozilla -remote 'openURL('http://mozilla.org',new-tab)'




Setting the Severity to 'major', as this will break a lot of scripts out there.
This definitely should be resolved before 1.7 gets released.
Comment 1 Christopher Aillon (sabbatical, not receiving bugmail) 2004-04-29 16:20:35 PDT
The fact that you are using doubly nested single quotations is probably a bad
idea.  That is most certainly NOT the documented behavior (there are no
quotation marks surrounding the URI string).
Comment 2 Karsten Bräckelmann 2004-04-29 16:36:05 PDT
Actually, this does not matter and is not the issue.

This one fails:
 $ mozilla -remote 'openURL(http://mozilla.org, new-tab)'
 Error: Failed to send command: 509 internal error

This works:
$ mozilla -remote 'openURL(http://mozilla.org,new-tab)'

Comment 3 Christopher Blizzard (:blizzard) 2004-05-04 19:59:09 PDT
Created attachment 147694 [details] [diff] [review]
patch

This moves the url check until after optional arguments are stripped.  (It's
barfing on a space in the middle of a url.)
Comment 4 Darin Fisher 2004-05-04 23:15:29 PDT
Comment on attachment 147694 [details] [diff] [review]
patch

r=darin
Comment 5 Christopher Blizzard (:blizzard) 2004-05-05 12:52:45 PDT
Checked in.  Thanks!
Comment 6 Karsten Bräckelmann 2004-05-19 16:33:32 PDT
Just installed Mozilla 1.7rc2 and tested this issue. Unfortunately this bug
still is valid in the 2004-05-14 build.

Didn't the patch made it into the rc2 release or should I reopen the bug?
Comment 7 Mike Connor [:mconnor] 2004-06-18 16:20:46 PDT
need to check this in on the aviary branch.
Comment 8 Karsten Bräckelmann 2004-06-20 07:45:08 PDT
Reopening.

As I mentioned before, RC2 still had this bug, as does official 1.7 release.
Comment #2 still applies with the very same error.
Comment 9 Christopher Aillon (sabbatical, not receiving bugmail) 2004-06-24 14:27:42 PDT
Comment on attachment 147694 [details] [diff] [review]
patch

This got checked in to trunk only, not to the branch.  It would probably be
nice to push on the branch though.
Comment 10 Mike Kaply [:mkaply] 2004-06-25 05:23:15 PDT
Comment on attachment 147694 [details] [diff] [review]
patch

a=mkaply for 1.7.1
Comment 11 Brian Ryner (not reading) 2004-07-06 03:50:52 PDT
I checked this in on the Aviary branch.  leaving the bug open in case you wanted
it that way for checking into the 1.7 branch.
Comment 12 Christopher Blizzard (:blizzard) 2004-07-23 11:32:16 PDT
Checked in on the 1.7 branch.  Marking fixed.
Comment 13 Christopher Blizzard (:blizzard) 2004-07-23 11:33:05 PDT
*** Bug 252024 has been marked as a duplicate of this bug. ***
Comment 14 Andrew Schultz 2005-06-30 22:11:10 PDT
*** Bug 229681 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.