Some character references lacking needed ; in test0.html

RESOLVED FIXED

Status

Core Graveyard
Viewer App
--
trivial
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Ernest Cline, Assigned: stephend)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

The period following &Egrave and &egrave at the end of two sentences is being
interpreted as part of the character reference name.  I believe that considering
the period to a valid character for a character reference name is correct SGML
behavior, so that including the semicolon is needed to get the presumably
intended behavior.

Reproducible: Always
Steps to Reproduce:
(Assignee)

Comment 2

14 years ago
--> me.
Assignee: viewer-app → stephendonner
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

14 years ago
Attachment #147370 - Flags: review?(adamlock)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: PC → All

Comment 3

14 years ago
Comment on attachment 147370 [details] [diff] [review]
Patch

r=adamlock

Looks correct. Are these files even used any more?
Attachment #147370 - Flags: review?(adamlock) → review+
(Assignee)

Comment 4

14 years ago
C:\moz_src\mozilla\webshell\tests\viewer\samples>cvs commit -m "Bug 242148.  Som
e character references lacking needed semicolon in test0.html.  r=adamlock" test
0.html
Checking in test0.html;
/cvsroot/mozilla/webshell/tests/viewer/samples/test0.html,v  <--  test0.html
new revision: 3.17; previous revision: 3.16
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.