If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox crashes and dies every time I try to print that page [@ nsViewManager::RenderViews() ]

RESOLVED DUPLICATE of bug 292055

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 292055
14 years ago
10 years ago

People

(Reporter: Keith, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6) Gecko/20040211 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6) Gecko/20040211 Firefox/0.8

Every time I try to print
http://www.scan.co.uk/products/productinfo.asp?WebProductID=112722 Firefox
crashes and dies.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.scan.co.uk/products/productinfo.asp?WebProductID=112722
2.From the File menu, select Print
3.Click "Print" on the print dialogue box.

Actual Results:  
Firefox will say it is preparing the print job and will then die and disappear
completely.

Expected Results:  
Print the page to a printer.

Updated

14 years ago
OS: SunOS → Solaris

Updated

13 years ago
Keywords: crash
I can crash this on linux (fedora core 1), but not on mac os x 10.3.4. tested
with 2004-07-27-08-0.9 (firefox aviary1.0 branch). confirming.

here's the talkback report:

http://hal.mozilla.org/reports/incidenttemplate.cfm?bbid=427090

SIGSEGV: Segmentation Fault: (signal 11)

/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/view/src/nsViewManager.cpp,
line 704
Stack Trace 	
nsViewManager::RenderViews() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/view/src/nsViewManager.cpp,
line 704]
nsViewManager::Display() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/view/src/nsViewManager.cpp,
line 86]
nsSimplePageSequenceFrame::PrintNextPage() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsSimplePageSequence.cpp,
line 901]
nsPrintEngine::PrintPage() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 3578]
nsPagePrintTimer::Notify() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPagePrintTimer.cpp,
line 92]
nsTimerImpl::Fire() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 386]
handleTimerEvent() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 450]
PL_HandleEvent() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
PL_ProcessPendingEvents() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 608]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsEventQueue.cpp,
line 395]
event_processor_callback() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
libglib-2.0.so.0 + 0x4939f (0x004f939f)
libglib-2.0.so.0 + 0x23faa (0x004d3faa)
libglib-2.0.so.0 + 0x25068 (0x004d5068)
libglib-2.0.so.0 + 0x253a0 (0x004d53a0)
libglib-2.0.so.0 + 0x259e3 (0x004d59e3)
libgtk-x11-2.0.so.0 + 0x11fa23 (0x00a6ba23)
nsAppShell::Run() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/firefox-1.0/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
libc.so.6 + 0x15475 (0x00d03475)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Summary: Firefox crashes and dies every time I try to print that page. → Firefox crashes and dies every time I try to print that page [@ nsViewManager::RenderViews() ]

Comment 2

13 years ago
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: 1.6) Gecko/20040614
Firefox/0.8

I have same problem with mail.yahoo.com (when logged in with a .sbcglobal.net
address). If necessary I can provide the html of a page that crashes it.

The computer is running Debian GNU/Linux sarge (firefox 0.8).
linux, printing to file
firefox/1.0_fi-FI crashes, TB2416885Y
trunk firefox-opt_2004-12-07-14Z wfm, no crash
please test with trunk build and verify or reopen
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 292055
Crash Signature: [@ nsViewManager::RenderViews() ]
You need to log in before you can comment on or make changes to this bug.