RFE - Suggest "invalid URL" dialogue have "search" button as well as "OK"

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Iain, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

I frequently type search terms into the address bar and (in spite of being a
Mozilla user for years) instinctively hit return.
Naturally this brings up the dialogue "the URL is invalid and cannot be loaded"
- which is dismissed by clicking "OK". It would save time and weltschmerz if the
search button appeared in this dialogue as an alternative to "OK" - then I could
smoothly proceed to doing the search that I had intended to do in the first place.
I doubt I'm the only one in the world, I suspect its a bug in Homo Sapiens OS.

Reproducible: Always
Steps to Reproduce:
1.Type search terms into address bar
2.Hit return
3.Slap forehead while exclaming "DOH!"

Actual Results:  
Mozilla functioned as designed - I just have a suggestion for tweeking the
design to make the "user experience" smoother.

Comment 1

15 years ago
WFM.

To make this work as you wish: Check "Internet Keywords" in
preferences->Navigator->Smart Browsing"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.