No autocomplete when username field is pre-populated

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: ipottinger, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040409 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040409 Firefox/0.8

Autocomplete does not autofill usernames and passwords when the username field
is pre-populated with either the full username (1) or a substring of the
username (2).  For instance: 

1) PayPal’s Login page (https://www.paypal.com/cgi-bin/webscr?cmd=_login-run)
remembers my email address.  When I revisit the page, my password is autofilled
by the Mozilla Suite but not by FireFox.

2) RBC Bank's Login page
(https://www1.royalbank.com/cgi-bin/rbaccess/rbunxcgi?F6=1&F7=IB&F21=IB&F22=IB&REQUEST=ClientSignin&LANGUAGE=ENGLISH)
prepopulates the client card field with 4519 since all RBC cards begin with
those numbers. When I revisit the page, my full card number and my password are
autofilled by the Mozilla Suite but not by FireFox. 

This is a problem on many sites.  I can easily offer a dozen more examples on
request.  This is the single most painful reminder for me that I am not using
the suite.  Instead of just clicking the sign-in/log-in button and going on my
merry way as I do with the suite, I must focus the username field, release the
mouse and delete a character from the end of whatever is in the username field,
press the down-arrow to activate the drop-down list, select the username, grab
the mouse again and click the sign-in/log-in button.

It's like a dripping faucet - a minor irritation that gets more and more
annoying with each repeated instance.



Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
#1 is bug 229762.
(Reporter)

Comment 2

15 years ago
Case 2 above is a situation where the prepopulated value is a leading-substring
of the username.  Bug 229762 and case 1 can be considered a subcase of case 2 -
meaning the leading-substring is the *complete* username.

Whether either of these bugs is a dupe of the other, I leave to the powers that
be to determine.
(Reporter)

Comment 3

15 years ago
The fix for Bug 229762 seems to address case 1 and 2.  Bravo!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040730
Firefox/0.9.1+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.