PgUp (Page Up), PgDn (Page Down) keyboard functions don't work

RESOLVED DUPLICATE of bug 206633

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 206633
14 years ago
14 years ago

People

(Reporter: K. M. Peterson, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040430 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040430 Firefox/0.8.0+

Although scrollbars work fine, as does mouse wheel (MS Mouse, with the latest
driver), keyboard PgUp and PgDn don't.  Home works.

Reproducible: Always
Steps to Reproduce:
Open page longer than window.  Hit PgDn.  
Actual Results:  
Nothing.

Expected Results:  
Page should scroll.

Comment 1

14 years ago
WFM with the latest trunk nightly Mozilla/5.0 (Macintosh; U; PPC Mac OS X
Mach-O; en-US; rv:1.8a) Gecko/20040504 Firefox/0.8.0+.

Reporter, were you using a trunk of branch nightly? What keyboard are you using
(iBook or a normal Apple "extended" keyboard, or whatever)?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
...
> 
> Reporter, were you using a trunk of branch nightly? What keyboard are you using
> (iBook or a normal Apple "extended" keyboard, or whatever)?
> 

I'm using the 'latest-trunk' build
(http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/Firefox-mac.dmg.gz
) ... Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a)
Gecko/20040504 Firefox/0.8.0+ still isn't working.

Keyboard is the "Apple USB Keyboard" - 1st generation, vintage 1999, the "mini"
that got a lot of criticism.  Note these keys all work in all other apps,
including Mozilla (1.7b build 20040421 last I checked).  Got any clues for
diagnosing this?

Comment 3

14 years ago
K.M., can you reproduce this using a new Firefox user profile?
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> K.M., can you reproduce this using a new Firefox user profile?

I redid my profile last week, from scratch... so I didn't think that was it...

But, I see that I'm wrong.  I added two accessibility settings that I couldn't
live without, and now see that this actually is an interaction with the
'accessibility.browsewithcaret' setting.  If the setting is on, the pgup and
pgdn keys do not work, if it's turned off this works normally.  

This looks like it may be related to Bug 206633 - should I close this one and
update that one?

(Sorry for not rethinking those settings before reporting this!)

Comment 5

14 years ago
If this only occurs with browsewithcaret set to true then yes, I think this is
probably a dupe of bug 206633. In which case we should resolve this as a dupe
and just leave 206633 open.

Comment 6

14 years ago
duping per comment 4 and comment 5.

*** This bug has been marked as a duplicate of 206633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.