Idea for unifying the location/address bar and search bar while improving functionality

VERIFIED WONTFIX

Status

()

Firefox
Toolbars and Customization
--
enhancement
VERIFIED WONTFIX
14 years ago
11 years ago

People

(Reporter: Ian Macfarlane, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The basic idea of this interface change/enhancement is to allow searches easily
and logically for users of any level of technical skill from the
location/address bar, doing away entirely with the need for a separate search
bar. The idea is not to make it more awkward for advanced users, in fact I
believe it is actually simpler and faster still.

The basic design I am suggesting is as follows. This replaces both the current
location bar and search bar.

<icon>[address or search term]<go><search><icon>

KEY:
The first <icon> represents the favicon, just as it does now

The text in [ ] represents the location (now also search) bar where you type

<go> This is a small go button. Lots of users will not use this, but _many_ less
advanced users (which Firefox will start to encounter more of) will simply not
know what to do otherwise. My parents are prime examples.

<search>This button would search using the current search engine. Rather than
just saying "Search" it should in my opinion also name the currently selected
search engine (e.g. "Google Groups" or "Google UK") underneath the word "Search"
(or perhaps something like "Search for this on"). This second line of text would
change when the search engine is changed. It is _critical_ that this button have
a tooltip (or something) pointing out the keyboard shortcut for web search (see
below) from the location/search bar.

<icon>This is the icon representing the search engine (e.g. the G icon for
google, the Y icon for yahoo etc) which you would click on to select the search
engine (as it is now, but without the search bar on the right). When shifting
between multiple search engines with the same icon (e.g. google uk, groups, etc)
you have the added benefit that the search button also gives the name of the
current engine.


Essentially, you get a a cleanup of the GUI and the cutdown in complication by
having to use a keyboard shortcut to jump to a search and back again. You press
enter for an address (and less advanced users have the comfort of a tiny 'go'
button), and you use the keyboard shortcut (now in the nightly builds) for web
search to do the search. This is the same as clicking on the search button.

Now there is a shortcut for web search put into the nightly builds, this is
obviously going to be the shortcut of choice for most advanced users. It's
quicker that having to jump to the search box first. As for the less advanced, I
am certain that most of them will feel more comfortable clicking a 'Search'
button than having to click to the search box (plus the particularly less
IT-literate may not know what to do without a search button to click).

As a last note, I don't feel that this will take up more toolbar real-estate, in
fact it may well increase the area available to the location bar, while allowing
longer searches to fit entirely on-screen.

Please consider this request for enhancement. I feel it would be a great
addition to Firefox 1.0

Ian 'Reve' Macfarlane

Reproducible: Always
Steps to Reproduce:
so basically, you'd replace a searchbox with an icon and a button?

this is a WONTFIX, sorry.  This is not simpler for users, its more complex.

- having a separate searchbox is visually obvious, not something that would have
to be figured out
- searching from the URL bar doesn't allow you to directly edit search terms to
search again/search different search engines, since the search result URL would
replace the value.
- this functionality was intentionally separated from the address bar for the
reasons above, among others.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 2

14 years ago
*** Bug 242804 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*** Bug 262609 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
*** Bug 276203 has been marked as a duplicate of this bug. ***
*** Bug 282576 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Comment 1 is correct, and I would add that the seach box (though small) is
highly satisfying to use. Whilst this may be a function of Google's being
head and shoulders above other search engines (on merit I might add), it
is gratifyingly clear to me that the search box provides a minor but
key usability positive feature of affordance 
http://www.usabilityfirst.com/glossary/main.cgi?function=display_term&term_id=66 
http://www.chrisgielow.com/2004/01/usability-design-affordance-turns-out.html

To put it simply, using this box is a joy and pleasure, and this matters
to those many of us who use a new web search operation 40, 50 or more
times per day.

Of course I am not suggesting that there should be no testing or
development of newer or different ideas, and in fact I would be
delighted each and every time the usability of the toolbar as a whole
is improved; but in general, I would guess that removing the search box 
is going to be a disbenefit to Firefox.

Comment 7

13 years ago
The best thing is to bring back mozilla unified URL/Search bar with search button.  

Comment 8

13 years ago
The developers should remember, they do not make firefox only for themselves but
also for users. Newbies can be confused when they find 2 places to type in the
URL (I saw many times URLs typed in into search bar). I'am advanced user of
mozilla. I use mozilla for long time and sometimes, when in hurry, I also type
in URL into search bar. Or type in search words into url bar and trying to find
search button (as I used to since long time). Making firefox so unfriendly which
type of users you expect to interest? The newbies will use any other browser
with one address bar (as they find example in books, magazines and net). The
"oldies" will go back to mozilla, because it is faster to type search word and
press Search, than thinking which bar should be used to search or too lazy to
learn new browser. Toolbar is also smaller in mozilla, so more space for useful
buttons. Oldies also will not brake their habits, like me: when using firefox, I
 always type in search word into URL bar and try to find Search button. Next I
realize that I am in firefox and do copy- paste into search bar. It really make
me nervous.

If you WONTFIX I WONTUSE.

I found a simple fix for this bug:
echo Deleting firefox...
rm -rf ./firefox
echo Installing mozilla...
tar -xjpvf mozilla-1.7.5.pl-PL.linux-i686.installer.tar.bz2
cd mozilla-installer
./mozilla-installer

Greetings to all newbies and oldies web browsers fans.
*** Bug 288655 has been marked as a duplicate of this bug. ***

Updated

11 years ago
QA Contact: bugzilla → toolbars
*** Bug 363203 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.