password manager do not remember the password for same domain in different TAB

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: footcow, Assigned: bryner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.6) Gecko/20040405 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.6) Gecko/20040405 Firefox/0.8

I connect myself to 3 URL on the same domain in 3 different tabs:
www.mydomain.com/
I have saved the password for this domain ... but each time the password
reminder open with empty fields ... 
Password manager seems to not remember that it have already gived the password
from another tab ...
I hope I'm clear ...

Reproducible: Always
Steps to Reproduce:
1.connect to a domain requiring a password (and save it in the password manager)
2.open another tab on the same domain
3.then the password manager open empty !

Actual Results:  
nothing special ... I have to enter the password by hand :o(

Expected Results:  
Presenting the password manager with saved login/password filled in the fields,
or do not ask anymore because I'm already logged on the same domain.

Comment 1

15 years ago
Reload the page in each subsequent tab. It fills in then. Actually, if you 
follow the steps that you have outlined you get exactly this, although your 
initial description would require reloads (if the tabs are opened all at once, 
you'd need to reload; if you saved a login and then opened a new tab, it will 
be filled out). 
 
This is minor, and marking WORKSFORME (the other alternative is WONTFIX). 
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.