Crash with general.useragent.override set to Mozilla/4.0

VERIFIED DUPLICATE of bug 83376

Status

()

Core
Preferences: Backend
--
critical
VERIFIED DUPLICATE of bug 83376
14 years ago
14 years ago

People

(Reporter: arromdee2@yahoo.com, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421

Set a pref for general.user.override to be anything starting with Mozilla/4.0. 
Run Mozilla.  Watch the crash.

Reproducible: Always
Steps to Reproduce:
1.Set a pref for general.user.override to be anything starting with Mozilla/4.0.
2.Run Mozilla.
3.Watch the crash.

Actual Results:  
crash

Expected Results:  
It should have used the user agent only when reporting the user-agent to web
sites, not internally, and not crash.

This is the crash message I get:

INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: Interrupted system call

Comment 1

14 years ago
This has been in the release notes for a long time.

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.