segmentation fault when visiting http://www.toolinux.com

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Miloz, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7b) Gecko/20040421

If I launch mozilla and enter www.toolinux.com, it receives data from
www.toolinux.com and then crash with a seg fault when trying to display.
If I try to access www.toolinux.com with a hidden tab (with open in a new tab),
it freezes for 4 secs and crash.

Reproducible: Always
Steps to Reproduce:
1.launch mozilla
2.trying to display www.toolinux.com
3.

Actual Results:  
segmentation fault

Comment 1

14 years ago
It doesn't crash on my Linux (2004050105) although the web is very slow and complex.

Comment 2

14 years ago
can you post a Talkback ID (using Firefox latest nightly build or Mozilla 1.7RC) ?
If not, please run mozilla in a a debugger:
"mozilla -g"
Once in GDB, start Mozilla with "GDB> run"
When Mozilla crashes, back in GDB, type "GDB> stacktrace" and attach the output
here (via "create a new attachment").
Keywords: crash, stackwanted
(Reporter)

Comment 3

14 years ago
Created attachment 147501 [details]
Output when using gdb

I am using 
Mozilla 1.7b
Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7b) Gecko/20040421

Updated

14 years ago
Keywords: stackwanted
Summary: segmentation fault when visiting http://www.toolinux.com → segmentation fault when visiting http://www.toolinux.com [@ nsHTMLReflowState::UseComputedHeight ]
That stack is obviously bogus, since UseComputedHeight does not call any
functions that could possibly call UseComputedHeight (and furthermore, because
UseComputedHeight could not possibly crash unless getenv() crashes, in which
case the crash wouldn't be in UseComputedHeight).

Olivier, you should know by now that stacks gotten from nigtlies via gdb are
utterly useless, since the binaries are stripped...

The only reasonable way to get a stack out of a nightly is talkback -- that's
why we have it.
Keywords: stackwanted
Summary: segmentation fault when visiting http://www.toolinux.com [@ nsHTMLReflowState::UseComputedHeight ] → segmentation fault when visiting http://www.toolinux.com

Comment 5

14 years ago
> Olivier, you should know by now that stacks gotten from nigtlies via gdb are
> utterly useless, since the binaries are stripped...
Boris, I know that, that's why I ask for a Talkback ID first, then again, there
are a few cases where the crash is located outside Mozilla and it's often a
quick way to distinguish a Flash, mplayerplug-in crasher for e.g., thus avoid
wasting your time trying to reproduce the crash. :)
Now, if the stacks can even be bogus (I didn't know that could happen) then I'll
stop asking for GDB stack traces.

Comment 6

14 years ago
WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040601
WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040601
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.