Firefox appears to use cached <script src=foo.js> file after server has been updated.

RESOLVED DUPLICATE of bug 234361

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 234361
14 years ago
14 years ago

People

(Reporter: Mark E. Bowles, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Attempting to get elaborate javascript package to run on Firefox (works on IE,
partially working on Mozilla 1.6).  While editing (on the server) javascript
files that are referenced into the pages by: <script
src="somefile.js"></script>, I find the original pre-edited versions being used
by Firefox.  

Killing and restarting Firefox does not help. "Touching" the html file
containing the <script> block does not help.  "Touching" the .js file does not
help. I can't find the cache on my pc, so I did not try clearing it.

This problem does not manifest in my copy of Mozilla, version string:
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113". 

Reproducible: Always
Steps to Reproduce:
1. Create small html file with <script src="name.js"></script> reference. 
Observe its correct behavior.
2.  Change the script on the server.
3.  View the html file on firefox again, e.g. using the refresh button.  

Actual Results:  
Saw the original script behavior

Expected Results:  
See the modified script behavior

Server is Linux Red Hat 9 running Apache 2.0.40.

Reproducibility: bug manifests in repeated attempts to fetch a single file; have
not attempted to reproduce over different files.
First off, Tools->Options->Privacy->Cache is where to clear it
Second, if the server tells the browser to cache it for a certain amount of
time,  Firefox won't go back to the server unless it expires from cache.  You
can hold shift and hit reload to force a reload.

Typing about:cache in the URL bar also brings up what's in cache
QA Contact: mconnor

Comment 2

14 years ago
Not sure if this apply to your situation.  Let's say if the browser is
instructed to refresh where everything should be refreshed.  As result, if the
main page was refreshed successfully the <script src="foo.js"> didn't.  Then
there are two existing bug you're looking for, not sure if it is a duplicate bug
due to lack of info.

Bug #234361 and Bug #236553
(Reporter)

Comment 3

14 years ago
After reading the description of the two bugs in the Zook's comment, I agree
that this bug is most likely a DUPLICATE of Bug #234361.  Bug #236553 appears to
be addressing a different set of symptoms, but could (or not) have the same
underlying cause.

To answer Zook's question: the problem manifests whether or not the HTML file
has been changed.  That is: view the page with FF.  Close FF (or not). Make
small change to .js file on server. Leave HTML alone. Re-view file with FF --
notice that FF is still using the old script.

Thanks for your help, Mike and Zook.

*** This bug has been marked as a duplicate of 234361 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.