make installer not leak

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
15 years ago
9 years ago

People

(Reporter: ajschult784, Assigned: ajschult784)

Tracking

({memory-leak})

Trunk
All
Linux
memory-leak
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patchlove])

Attachments

(2 attachments)

(Assignee)

Description

15 years ago
The installer leaks quite a bit.  Most, but not all, are shutdown leaks.  I'll
attach a valgrind leak log.  Some of these would be fixed by the patch in bug
101471.
(Assignee)

Comment 1

15 years ago
Created attachment 147528 [details]
valgrind leak log

LEAK SUMMARY:
   definitely lost: 6902 bytes in 95 blocks.
   possibly lost:   732 bytes in 12 blocks.
   still reachable: 611930 bytes in 2365 blocks.
(Assignee)

Updated

15 years ago
Depends on: 242524
(Assignee)

Comment 2

15 years ago
Created attachment 147599 [details] [diff] [review]
patch

This fixes the installer leaks not fixed by the patch in bug 101741 except for
the component duplicates, which I hope to fix in bug 242524.

The leaks within gtk_init are unfixable.  The other leaks in the valgrind log
seem to be elsewhere in gecko.
(Assignee)

Updated

15 years ago
Attachment #147599 - Flags: review?(bsmedberg)

Updated

15 years ago
QA Contact: bugzilla → agracebush

Updated

15 years ago
Attachment #147599 - Flags: review?(bsmedberg) → review+
(Assignee)

Updated

15 years ago
Attachment #147599 - Flags: superreview?(dveditz)
Product: Browser → Seamonkey
(Assignee)

Comment 3

13 years ago
*** Bug 333316 has been marked as a duplicate of this bug. ***
Attachment #147599 - Flags: superreview?(dveditz)
Comment on attachment 147599 [details] [diff] [review]
patch

sr=dveditz if we're still using this.
Attachment #147599 - Flags: superreview+
Status: NEW → ASSIGNED
Whiteboard: [patchlove]
QA Contact: agracebush → xpi-packages

Comment 5

9 years ago
This is on old installer, which is gone.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.