All users were logged out of Bugzilla on October 13th, 2018

Import VCalendar 1.0 (vcs) correctly

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
15 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040306 Mozilla Sunbird/0.1.1+

I dumped the events from my EPOC based Symbian phone (Sony Ericsson) to a .ics
file. Viewing it in Moz.Cal shows the correct events. Recurring events are not
shown though.


Reproducible: Always
Steps to Reproduce:
1. Use this event:
BEGIN:VCALENDAR
VERSION:1.0
BEGIN:VEVENT
UID:762
SUMMARY:weekly test
DTSTART:20040503T160000Z
DTEND:20040503T170000Z
X-EPOCAGENDAENTRYTYPE:APPOINTMENT
CLASS:PUBLIC
DCREATED:20040502T220000Z
RRULE:W1 MO #0
LAST-MODIFIED:20040503T101900Z
PRIORITY:0
STATUS:NEEDS ACTION
END:VEVENT
END:VCALENDAR

2. Open it in Moz.Calendar
3. View the event and find any recurrences

Actual Results:  
The event is shown in the calendar. The specified recurrence (RRULE:W1 MO #0)
can't be found.

Expected Results:  
All recurrences should also be shown.

I viewed the same event on my iPod, where the recurrence works fine. Same goes
for my phone (SE P800).

I tried generating the same event from Moz.Cal. The main difference I could find
was the version of the VCALENDAR (namely 1.0 for EPOC, 2.0 for Moz.Cal) and
(correspondingly?) the RRULE value (namely RRULE:W1 MO #0 for EPOC, 
RRULE:FREQ=WEEKLY;INTERVAL=1;BYDAY=MO for Moz.Cal)
the solution I can see is somewhat related to bug 242465

Updated

13 years ago
QA Contact: gurganbl → general

Comment 2

13 years ago
This isn't a valid icalendar rrule.  EPOC needs to sort out how they store this sort of thing.  Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 3

13 years ago
It looks like a valid vCalendar 1.0 rule (vCalendar 1.0 sec 2.1.11).
(BTW, vCalendar 1.0 files should be saved with a .vcs suffix.)
W1 is FREQ=WEEKLY with INTERVAL=1.  MO is BYDAY=MO.  The #0 means repeat forever.

Currently sunbird does not import/export vCalendar 1.0 recurrences.
vCalendar 1.0 is still significant because it is a Versit Consortium standard, while rfc2445 (vCalendar 2.0) never reached standard status, so many manufacturers implement vCalendar 1.0 rather than vCalendar 2.0, and continue to implement it so people can import their data when they upgrade to a new device.

Marking enhancement, somebody may implement a converter to improve import and/or export for vCalendar 1.0 files.
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: RRULE does not get interpreted with VEVENT dump from EPOC Agenda → RRULE does not get interpreted with VEVENT dump from EPOC Agenda [import vcs vCalendar 1.0]
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Component: General → Import and Export
OS: Windows 2000 → All
QA Contact: general → import-export
Hardware: PC → All
Whiteboard: [qa discussion needed]
Version: unspecified → Trunk

Comment 5

12 years ago
Confirming. Because calendar 1.0 is still slated to support mobile sync, it may become important for us to support VCALENDAR 1.0 formats 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: RRULE does not get interpreted with VEVENT dump from EPOC Agenda [import vcs vCalendar 1.0] → Import VCalendar 1.0 (vcs) correctly
Whiteboard: [qa discussion needed]
Duplicate of this bug: 346637
Duplicate of this bug: 372413

Comment 8

11 years ago
The extension "vcs support" allows the import and export of VCALENDAR 1.0 files.  It allows the import of the example in comment #0 correctly.  It is currently in the AMO sandbox at:

https://addons.mozilla.org/en-US/thunderbird/addon/4721

Reviews, feedback and notice of any bugs (I'm sure there are still plenty) would be welcome.

Updated

11 years ago
Version: Trunk → unspecified
WONTFIX in core, please use the extension.
Status: NEW → RESOLVED
Last Resolved: 13 years ago4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1201297

Comment 11

3 years ago
Ok my new attempt to get this in have been Duped here.  I think a decision not to support the invite format used by the second largest mobile maker in the world is questionable.  The extension will not allow an automated accept /decline from within the email.
Hi Matt, thanks for the report.

The VCalendar 1.0 specificaion is the predecessor to iCalendar standard and was created by the IMC in 1996. It was superseded by rfc 2445 in 1998, which is an IETF standard. This was again revised in 2009 with rfc 5545. While I understand that there are still some applications using the VCalendar specification, I think it is safe to say that interoperability with VCalendar does not need to be added to Lightning. It would just add additional complexity for a specification that is obsolete.

Please file a bug with Samsung to move to more recent technology, or use the above mentioned extension.

Comment 13

3 years ago
Thanks Fallen,  these calendar things really are not my expertise.  But I will learn eventually I hope.
No worries, it was probably good that you filed the bug: now everyone reading this bug will understand the background a bit better :)
You need to log in before you can comment on or make changes to this bug.