Setting about: as Thunderbird start page results in XML Parsing Error

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: riscky, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Using about: as the Thunderbird start page produces an invalid XML file.



XML Parsing Error: undefined entity Location:
jar:resource:///chrome/en-US.jar!/locale/en-US/global/about.xhtml Line Number
69, Column 23:<a id="mozlink" href="&releaseURL;">&brandShortName; &version;</a>
----------------------^

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Thunderbird start page using about: → Setting about: as Thunderbird start page results in XML Parsing Error
(Reporter)

Updated

14 years ago
OS: MacOS X → All
Hardware: Macintosh → All

Comment 1

14 years ago
*** Bug 266202 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
As I noted at the dupe -- I see this symptom in the trunk builds of TB -- 
currently "0.6+" for 11/08 -- but not in the aviary builds (0.8, 0.9).
Severity: trivial → minor

Comment 3

14 years ago
(In reply to comment #2)
> As I noted at the dupe -- I see this symptom in the trunk builds of TB -- 
> currently "0.6+" for 11/08 -- but not in the aviary builds (0.8, 0.9).

Well I am using 0.8, not a trunk build
(Reporter)

Comment 4

14 years ago
Hmmm... I have this issue with aviary builds as well... I'm using 0.9 release...

version 0.9 (20041103) for OS X and I have the parsing error...

Comment 5

13 years ago
*** Bug 295499 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
I've had my start page set to "about:" since I first investigated this bug, but 
haven't seen the symptom of this bug until I started today's nightly build.
Last build I used that didn't manifest the bug was the 0515.  Windows 2000.

Comment 7

13 years ago
Created attachment 184835 [details] [diff] [review]
Patch
Attachment #184835 - Flags: review?(mscott)
(Assignee)

Comment 8

13 years ago
what is releaseURL used for?  In browser, this just points to mozilla.org and
has nothing to do with releaseNotes per say. 

Comment 9

13 years ago
(In reply to comment #8)
> what is releaseURL used for?  In browser, this just points to mozilla.org and
> has nothing to do with releaseNotes per say. 

It's used on the about: page for the "Thunderbird [version]" link. If you think
this is not worth fixing it (since the link would need to be updated for 1.1,
1.2, etc.) we could also just mark this bug invalid since there is no real UI to
see the about: page (Firefox has a url bar, Thunderbird not).
(Assignee)

Comment 10

13 years ago
(In reply to comment #9)
>we could also just mark this bug invalid since there is no real UI to
> see the about: page (Firefox has a url bar, Thunderbird not).

I like that idea :)

Ok ;)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Attachment #184835 - Flags: review?(mscott)
(Reporter)

Comment 12

13 years ago
Such a shame (being marked as invalid)... however about: should display
about:blank instead of the parsing error.
I don't think there is a easy way to do that (would require too much code for
little use).
You need to log in before you can comment on or make changes to this bug.