Closed Bug 24244 Opened 25 years ago Closed 25 years ago

Upper part of long documents incorrectly drawn.

Categories

(Core :: XUL, defect, P2)

x86
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: jst, Assigned: pavlov)

Details

Attachments

(1 file)

Loading a long document paints the upper part of the document incorrectly,
scrolling down some paints that part of the document correctly. I have a
testcase available that I will attach.

I noticed this problem on

	http://slashdot.org/askslashdot/00/01/13/2330201.shtml
I only se this problem on Linux (with GTK).

The test I just attached is a html file containing

some text 0
some text 1
some text 2
...
some text 1000

When I view this in mozilla (a couple of hours old) the document is painted
correctly when I scroll down so that the line "some text 9" is not displayed,
from there on down to the bottom of the document everything seems OK but nothing
above "some text 9" is painted correctly if even pained at all.

Could this be some 16 bit values wrapping around somewhere? If I remove 10 lines
from the testcase then mozilla paints the doc as it should!
Assignee: trudelle → pavlov
Priority: P3 → P2
Target Milestone: M14
reassigning to pavlov as p2 for m14
Status: NEW → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
This is working now.  I believe that Patrick Beard's view manager changes fixed
this.
This is not working for me yet (about 1 hour old tree). I'll try this again
tomorrow after rebuilding and if it's not working I'll reopen this bug.
ok.  I was seeing this a day or so ago, but I didn't see it in my latest tree.
Status: RESOLVED → REOPENED
I rebuilt yesterday (after adding my last comment) and the problem is still
there. Reopening this bug.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
Putting on beta1 radar.
Keywords: beta1
resolving as wfm, jst@citec.cfi: if you still see this then reopen with
sufficient information for us to reproduce (just saying I still see it is not
sufficient).
Status: REOPENED → RESOLVED
Closed: 25 years ago25 years ago
Resolution: --- → WORKSFORME
This is indeed fixed in todays build, the test documents are both correctly
redrawn now :).
thanks, jst! marking verified then
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: