If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

submit button with "submit(); return false" not working

VERIFIED FIXED in mozilla1.8alpha1

Status

()

Core
DOM: Events
--
major
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: Rob Borek, Assigned: Brian Ryner (not reading))

Tracking

({regression})

Trunk
mozilla1.8alpha1
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040503 Firefox/0.8.0+ (BlueFyre)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040503 Firefox/0.8.0+ (BlueFyre)

On the page https://groupwise.wlu.ca:51443/servlet/webacc (which is a Novell
Groupwise login page), the Submit button does not work - clicking Submit does
nothing. This is a regression - the 20040430 trunk worked fine, stopped working
with 20040502 (not sure if 20040501 worked).

Reproducible: Always
Steps to Reproduce:
1. Enter any login and password information
2. Click on Login

Actual Results:  
Nothing

Expected Results:  
Proceeded with logging in to Groupwise
> the 20040430 trunk worked fine

2004-04-30 when?  morning?  Evening?   2004-05-01-08 does not work.
Actually, this looks like likely fallout from bug 60212.. I'm not seeing this in
my build (which has all the changes I landed on the 30th, but not the event change).
Assignee: general → events
Component: JavaScript Engine → DOM: Events
QA Contact: pschwartau → ian
(Reporter)

Comment 3

14 years ago
(In reply to comment #1)
> > the 20040430 trunk worked fine
> 
> 2004-04-30 when?  morning?  Evening?   2004-05-01-08 does not work.

It was a custom build of FireFox, built in the morning.
Flags: blocking1.8a?

Comment 4

14 years ago
Also seeing this at: http://mail.atl.devry.edu/servlet/webacc

Pressing the Login button does nothing.  I've tested using the Official Win32
nightly build from 20040430 - works fine with this build but not with any
official Win32 builds from 20040501 to present.  Apparently the bug is also
showing in Mac builds, as evidenced by this thread:
http://forums.mozillazine.org/viewtopic.php?t=74443
Sean, I doubt that you're seeing this bug, since my build with the fix for bug
242503 worksforme on that site (so you're probably seeing a variant of that
problem).  If you could retest once that patch is checked in, that would be much
appreciated.
Depends on: 60212

Comment 6

14 years ago
Same as bug 242709. Closing as a duplicate of that one because it has a simple
test case some analysis.

*** This bug has been marked as a duplicate of 242709 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Flags: blocking1.8a?

Comment 7

14 years ago
My mistake. The same checkin created this bug and bug 242709, but the testcases
are slightly different and the mechanism of breakage is slightly different as
well. Reopening. Note this is almost certainly the same as bug 242439.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

14 years ago
Assignee: events → bryner
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 242439

Updated

14 years ago
No longer depends on: 242439

Comment 8

14 years ago
*** Bug 242439 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Created attachment 148155 [details]
simpler test case

Updated

14 years ago
Flags: blocking1.8a?

Updated

14 years ago
Keywords: regression

Updated

14 years ago
Blocks: 242714

Comment 10

14 years ago
*** Bug 242469 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
*** Bug 242976 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Summary: JavaScript Submit button not working → submit button with "submit(); return false" not working
Evem the wikipedia edit form doesn't work.
Blocks: 243703

Comment 13

14 years ago
This bug also stops paypal transactions, so most ebay users won't be able to pay
for their auctions in an efficient manner.
Blocks: 243260

Comment 14

14 years ago
*** Bug 243703 has been marked as a duplicate of this bug. ***

Updated

14 years ago
No longer blocks: 243260

Comment 15

14 years ago
*** Bug 243260 has been marked as a duplicate of this bug. ***
No longer blocks: 243703
bryner, is this gonna get fixed soon?

/be
Bug is all/all.

(And for me (using os x)) I didn't find even one form that works in last nightlies)
(Assignee)

Comment 18

14 years ago
Created attachment 148620 [details] [diff] [review]
patch

I think this is the patch we want for this and bug 242709.  It passes all of
the testcases here and does not regress any of the DOMActivate tests.
(Assignee)

Comment 19

14 years ago
Created attachment 148621 [details] [diff] [review]
diff -w of the above
(Assignee)

Updated

14 years ago
Attachment #148620 - Flags: superreview?(jst)
Attachment #148620 - Flags: review?(bzbarsky)
Comment on attachment 148620 [details] [diff] [review]
patch

Oh, heh. r=bzbarsky
Attachment #148620 - Flags: review?(bzbarsky) → review+
Blocks: 242709
Does jst really need to look at this or can someone else sr it?
Comment on attachment 148620 [details] [diff] [review]
patch

sr=brendan@mozilla.org.

/be
Attachment #148620 - Flags: superreview?(jst) → superreview+

Updated

14 years ago
No longer blocks: 242714

Comment 23

14 years ago
*** Bug 242714 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 24

14 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 25

14 years ago
Clearing blocking1.8a? as this has been fixed.
Flags: blocking1.8a?
I tried the last build of firefox:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040519
Firefox/0.8.0+

and it is still there
I can't send any form with MacFirefox build since 1may 

Comment 27

14 years ago
Asaf: most likely you're seeing bug 244698. This too is fixed in (very) recent
builds.
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.8alpha1
You need to log in before you can comment on or make changes to this bug.