No scrollbars provided to scroll attachment list that extends beyond visible message pane area

RESOLVED DUPLICATE of bug 223340

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 223340
14 years ago
4 years ago

People

(Reporter: Daniel Küstner, Assigned: Scott MacGregor)

Tracking

unspecified
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421

When the attachment list of a message is to long to be displayed fully, a scroll
bar is missing to show the rest of the attachments.

Additionally, at the same time, the scrollbar in the folder pane is
disappearing. It reappears after closing and opening a folder.

Using TB 0.6f on Mac OS X with default (Pinstripe) Theme

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 147615 [details]
Screen shot of mail with many attachments

Adding screenshot.

Comment 2

14 years ago
Confirmed using Thunderbird-Mac/0.6. Daniel, out of curiosity, did 0.5 suffer
the same problem? How about Thunderbird-Win/0.6?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Scrollbars disappearing when having long attachment list → No scrollbars provided to scroll attachment list that extends beyond visible message pane area
(Reporter)

Comment 3

14 years ago
TB 05 on Mac is similar - the only difference is, that 06 has a minimal vertical
space for the message text, while with 05 the whole text space is eaten by the
attachments, when there is no text.

I can't try TB on Win, bc I don't have a Win computer. I could try Linux, but I
had to download TB for Linux, which is not very funny with a dialup connection.

Comment 4

14 years ago
Related to bug 122180?
That one was fixed recently, and the real cause was bug 195355, so probably
Thunderbird was affected as well.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 220402 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 6

14 years ago
Mike, why do you think this a dup of bug 220402? That bug describes a
malfunctioning scrollbar, whereas this bug is about the lack of one.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

14 years ago
*** Bug 256940 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
There is a similar problem with long address lists. If the address list is
expanded then there are no scrollbars. This occurs in TB 0.7.3 and TB 0.8, both
checked with Windows XP using default themes.

Comment 9

14 years ago
(In reply to comment #8)
> There is a similar problem with long address lists. If the address list is
> expanded then there are no scrollbars. This occurs in TB 0.7.3 and TB 0.8, both
> checked with Windows XP using default themes.

I am having this long address list problem on TB 0.8 on OSX and Linux as well.

If the address list is long enough, you won't see any of the rest of the email
(subject, body, attachments, etc.)

Comment 10

14 years ago
I'm seeing the same problem with attachments scrollbar using Mozilla mail
(Debian package): Mozilla 1.7.3
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040924 Debian/1.7.3-2

Comment 11

14 years ago
Still present in Thunderbird 0.9 (20041103).
Possibly related to bug 223340.

Comment 12

14 years ago
A more extreme example of this bug can be seen at attachment 165973 [details], from
bug 269596.  I'm not sure if that's a dupe or not -- in that instance, the 
attachment pane expanded to complete obscure the message -- but it's the same 
basic problem.  Differences may be due to theme choices or perhaps Mac vs. 
Windows.

Comment 13

14 years ago
*** Bug 269596 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
On further examination, the problem at that attachment is from a standalone 
message window, which apparently does not set a minimum height for the content 
portion of the window; whereas the 3pane does.

I see this same issue on Windows, so updating the platform.

I tried adding this to userChrome.css, but the result is unsatisfactory:
#attachmentView {
  overflow: auto !important;
  max-height: 28em !important;	
}

The max-height is not used as expected; the attachment box never gets any taller 
than the default, 1-attachment height, and a horizontal scrollbar obscures the 
contents of the view.  But maybe somebody can use that as a starting point to 
investigate this a little more in-depth...
OS: MacOS X → All
Hardware: Macintosh → All

Comment 15

14 years ago
(In reply to comment #12)
> A more extreme example of this bug can be seen at attachment 165973 [details], from
> bug 269596.  I'm not sure if that's a dupe or not -- in that instance, the 
> attachment pane expanded to complete obscure the message -- but it's the same 
> basic problem.  Differences may be due to theme choices or perhaps Mac vs. 
> Windows.

This apears in Mozilla Thunderbird 0.9 (win32) too.

Comment 16

14 years ago
*** Bug 270222 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
Note that this happens on Mozilla MailNews as well. The Product on this bug says
Thunderbird. Shouldn't this be changed to MailNews?

Comment 18

14 years ago
(In reply to comment #17)
> Note that this happens on Mozilla MailNews as well.

It does?  Please check the screenshot attached to this bug; if you still think 
Moz is doing a similar thing, attach a screenshot of *that*.

Comment 19

14 years ago
Created attachment 166237 [details]
Screenshot of Mozilla 1.7.3 on Linux

Notice the missing scrollbars in the attachment window and the message window.
This is Mozilla 1.7.3 on Debian Linux for i386.

Comment 20

14 years ago
Comment on attachment 166237 [details]
Screenshot of Mozilla 1.7.3 on Linux

No, that's bug 247833.
Attachment #166237 - Attachment is obsolete: true

Comment 21

13 years ago
*** Bug 280927 has been marked as a duplicate of this bug. ***

Comment 22

13 years ago
*** Bug 288343 has been marked as a duplicate of this bug. ***

Comment 23

13 years ago
*** Bug 302343 has been marked as a duplicate of this bug. ***

Comment 24

13 years ago
Created attachment 197426 [details]
Thunderbird tries to display every attachment at once in the preview window

Confirmed as incredibly annoying. Present in Thunderbird 1.0.6 for Windows. See
attached picture. It's organized, but it could use a scroll bar.

Comment 25

13 years ago
*** Bug 322766 has been marked as a duplicate of this bug. ***

Comment 26

12 years ago
That bug is still present in Tb 1.5 on Linux & Windows. If there are MANY attachments (lets say 42), the #attachmentView will clobber the text of the message completely.

To fix, users can add something like the following to their userChrome.css:

#attachmentView
{
        -moz-appearance: none !important;
        height: 34px !important;
        overflow: auto !important;
}

IMO, that should be default. Maybe not with exactly those values, but something very similar to this at least.

Updated

12 years ago
Flags: blocking-thunderbird2?

Comment 27

12 years ago
On both counts, too much header info and too large of an attachment pane, this bug can render a message unreadable.  This bug gets my first vote.

Comment 28

12 years ago
On both counts, too much header info and too large of an attachment pane, this bug can render a message unreadable.  This bug gets my first vote.

I'm experiencing both issues with Thunderbird version 1.6a1 (20060119) on winxpprox64beta

Comment 29

12 years ago
I'm using the CSS from Comment #26 with a little change:
        max-height: 75px !important;
instead of
        height: 34px !important;
and it works great (if only one attachment is in the message it is not growing to 75 pixels, if more it is growing to no more than 75 pixels). Please fix this part, it could not be easier to.
(Assignee)

Comment 30

12 years ago
I tried the CSS in comment 26 and comment 29 and I didn't get scrollbars inside the attachment box so you don't know that you can scroll the attachment view. Anyone have any CSS magic that will add scrollbars to the attachmentList object itself? It may not be possible to get a scrollbar inside a xul description widget but would be curious to hear results. 

Comment 31

12 years ago
(In reply to comment #30)
> Anyone have any CSS magic that will add scrollbars to the attachmentList
> object itself?

I haven't been able to make that work.

Furthermore, with the CSS from comment 26/29 I don't see the attachmentView object growing in height; as I described in comment 14, I never see the attachmentView growing beyond one row if it has overflow:auto.  However, this:
===================
#attachmentView {
  max-height: <whatever -- I'm using 12em>;
  overflow-y: auto;
  -moz-box-orient: vertical;  /* this helps */
}
===================
*does* provide a scrollbar -- an ugly one that scrolls the "Attachments" label along with the box.  Unfortunately, I'm seeing the scrollbar even with a single attachment -- very similar to the problem with the CSS I put up at bug 240313.

The vertical alignment also puts the label above the box, which is better when there are many attachments but not so good if there is only one or two.


> It may not be possible to get a scrollbar inside a xul description
> widget but would be curious to hear results. 

I notice that applying a max-height that widget results in some unfortunate display glitches; try using this (don't worry about the scrollbar):
===================
#attachmentView {
  max-height: 12em;
}
#attachmentList {
  max-height: 8em;
  overflow-y: auto;
}
===================
See the overflow at the bottom when there are many attachments?  That looks 
like a bug either with the widget itself or with some pretty basic layout code.

Also notice that with several rows of attachments, the vertical arrow keys 
don't work as expected to navigate thru the list.

I think this widget sucks.


How about this: Replace the 'description' widget with a real listbox, with semantic columns instead of space-saving columns (including a column to show attachment size and maybe even one for MIME type) -- and with a splitter 
between message body and attachment list.

Or, revert to a suite-style attachment panel.

Comment 32

12 years ago
Something has changed on the trunk -- the CSS in comment 31 no longer displays as desired, but instead shows a big horizontal scrollbar that obscures the attachment panel entirely.

Comment 33

12 years ago
*** Bug 341243 has been marked as a duplicate of this bug. ***

Comment 34

12 years ago
(In reply to comment #32)
> the CSS in comment 31 no longer displays
> as desired, but instead shows a big horizontal scrollbar that obscures the
> attachment panel entirely.

The following simple css works not too badly for me. Not great, either, but maybe it's a step in the right direction:
#attachmentView {
  overflow: -moz-scrollbars-vertical;
}

The problems I see so far are:
1. the damn scrollbar is always drawn, even for a single attachment. It looks like the attachment area is always sized to be a px or two smaller than the attachment window, making the scrollbar always appear just to scroll that extra redundant space. Resizing attachmentView doesn't fix it. This isn't so bad, but it's still not great.
2. you can't force it to size the attachment pane any bigger than the default (~4em for me), except by upping the min-height (which results in big panes for small attachments) or by setting the -moz-box-flex to 1 (which causes all attachment panes to cover about 50% of the mail window and again results in big panes for small attachments).
3. setting min- or max-height to a percentage should make it calculate from the height of the surrounding box (or so I thought). In which case, I think it should be messagepanebox. Instead it does nothing. It'd be really handy if it worked. Anyone know if this is a xul bug or if I'm just missing something?

Other than that, I like Mike's suggestion of a listbox and splitter (comment 31). It might end up much faster and simpler than trying to work around uncooperative css.

Comment 35

12 years ago
*** Bug 355546 has been marked as a duplicate of this bug. ***

Comment 36

12 years ago
(In reply to comment #31)
> I notice that applying a max-height that widget results in some unfortunate
> display glitches; try using this (don't worry about the scrollbar):
>  [CSS deleted]
> See the overflow at the bottom when there are many attachments?  That looks 
> like a bug either with the widget itself or with some pretty basic layout
> code.

That overflow is also very like that seen in attachment 224219 [details] (from 
bug 41994), where an All Headers envelope panel overflows into the status bar.
I'm not sure if the widget that's overflowing in that screenshot is the Description widget, because there isn't a working DOM Inspector for TB2.
The behavior seen there is new to 2.0, however; 1.5 doesn't show it.
(Assignee)

Updated

12 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Comment 37

11 years ago
Version 1 patch on bug 223340 that should fix this.

Comment 38

11 years ago
Fixed in bug 223340. Bug 370792 is for further improvements to the UI.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 223340
You need to log in before you can comment on or make changes to this bug.