Get rid of the clear button in the quick search bar

RESOLVED DUPLICATE of bug 243307

Status

RESOLVED DUPLICATE of bug 243307
15 years ago
15 years ago

People

(Reporter: mscott, Assigned: mscott)

Tracking

unspecified
Thunderbird0.7
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
We can make better use for this space than a clear button. We don't expose clear
buttons in the google search bar of the browser or other areas where you enter
search criteria on a view.

It would be really cool if we showed status text to the right of the quick
search bar instead of the clear button. i.e.
 "34 Messages Found"
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.7

Comment 1

15 years ago
I love the clear button ;-)

If I'm around with the mouse and want to clear a search (= to see all messages
again - a very common scenario), there's no need to reach for the keyboard when
there's a button.

The google-bar in Firefox is different because it doesn't react to changes
instantly. Another example for a well placed clear-button is the one in Winamp
5's music library - the search-bar there also reacts to changes instantly.

My opinion is that there needs to be an ability to clear a search by mouse only
in a search-bar with instant reaction - if the clear button is that much hated
it could be replaced by a context-menu-item of the bar.

just thoughts, i don't want to offend anybody. i hope it's alright to post this
here.

Comment 2

15 years ago
I agree with Patrick.

Comment 3

15 years ago
Although I don't have a problem with the Clear button per se, I do think there
should be some feedback about the result of a search. In Firebird's about:config
(I'm still using 0.6.1+ due partly to the new password manager), there's no
Clear button next to the input area. It's unclear what folder or account one is
searching in the Mail search box, so that may be another piece of info that can
be displayed (tho the button isn't that big).

Comment 4

15 years ago
(In reply to comment #3)
> Although I don't have a problem with the Clear button per se, I do think there
> should be some feedback about the result of a search.

The statusline at the bottom of the application-windows is the place to echo 
this kind of information - that's where the user expects this kind of 
information. This didn't come to my mind when writing my orignial comment #2 so 
I'm adding it now.

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 243307 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.