Alt+D does not select location bar with Caps Lock on

VERIFIED DUPLICATE of bug 178110

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 178110
14 years ago
14 years ago

People

(Reporter: InvisiBill, Assigned: Blake Ross)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040503 Firefox/0.8.0+ (BlueFyre)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040503 Firefox/0.8.0+ (BlueFyre)

With Caps Lock turned on, Alt+D does not select the location bar for typing.

Reproducible: Always
Steps to Reproduce:
1. Click anywhere on a page to unselect the location bar.
2. Turn Caps Lock on.
3. Press Alt+D (location bar hotkey).

Actual Results:  
Location bar is not selected. System plays default error sound.

Expected Results:  
Location bar should be selected with Alt+D even with Caps Lock on.

http://bugzilla.mozilla.org/show_bug.cgi?id=158679 states that shortcut keys for
viewing mail messages do not work if Caps Lock is on. These are probably
related, and there may be other cases of this in the suite as well. Based on
that bug, this one is probably all operating systems also.

Comment 1

14 years ago
bug 184050 and bug 211888 are both duped against bug 178110. They all described
the same problem. Bug 178110 (the original one) was resolved fixed, but I don't
think it's fixed any more. But I'm a little reluctant to reopen that bug,
because they bugs seem to have different understandings of the problem :-)

Comment 2

14 years ago
This looks like Bug 178110 indeed, I see the same behaviour using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040505
Firefox/0.8.0+
Keywords: regression

Comment 3

14 years ago
Marking as NEW based on comments. Reproducable with latest nightly on w2k as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
*** Bug 243060 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
It looks like the fix added for Bug 178110 was removed again as part of the fix
for Bug 231381:

http://bonsai.mozilla.org/cvsquery.cgi?date=explicit&mindate=2004-01-18+22%3A46&maxdate=2004-01-18+22%3A46
Severity: normal → minor

Comment 6

14 years ago
*** Bug 245268 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Why does it work in Seamonkey but not in Firefox?
I recommend reopening bug 178110, and duping both bug 242643 and bug 203993 to it. 
No longer blocks: 203993

Comment 9

14 years ago

*** This bug has been marked as a duplicate of 178110 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 10

14 years ago
Hmm... the mailnews navigation keys don't work with CapsLock either.

Updated

14 years ago
Status: RESOLVED → VERIFIED

Comment 11

14 years ago
*** Bug 203993 has been marked as a duplicate of this bug. ***
No longer depends on: 178110
You need to log in before you can comment on or make changes to this bug.