Select dropdown does not drop down when inside a block-level element which is inside a position: relative inline element

RESOLVED DUPLICATE of bug 241638

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED DUPLICATE of bug 241638
14 years ago
13 years ago

People

(Reporter: Jon Erland Madsen, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

This bug might be a subtility (dumb programmer) and not a bug, but it works in
IE and Opera.

Look at the calculator on the adress above. In the foil marked "Valg" there is a
select box where you can choose the number of loan terms every year. It is
unselectable. I have also made other calculators with "foils", and the same
problem arises there.

I have checked for the following possibilities:

1) That the <form> tags are missing (they are, in the span, but it doesn't
explain this problem),
2) That the select box is written dynamically into a span. I have made a small
demonstration (on http://www.jiffymade.com/dev/test/testdynamiskselect.htm)
which demonstrates that this is not the problem.
3) There are three <span>-fields in the document. Is one "layer" laying on top
of the other? I have tried to de-activate the others, without avail, and the
demonstration shows this is not the case. 
4) The "selected" option is set dynamically. That is not the problem. The box is
malfunctioning also without any options preselected.

I have made a workaround for Gecko, by simply writing out text input boxes
instead of <select>. That is of course unsatisfactory, but it lays here:
http://www.jiffymade.com/dev/dn/renter3.htm

Reproducible: Always
Steps to Reproduce:
1. Open the calculator on the adress above
2. Select the foil top with the word "Valg"
3. Try to make a selection in the <select> box. It is not possible. 




I have made many calculators, but the select boxes are normally embedded in the
normal, traditional html-code, where they work perfect in all browsers.

When writing them out dynamically, in virtual "foils", the problem arise.

The calculators are for mass distribution on high-traffic internet sites, and
should therefore work on most browsers.

Comment 1

14 years ago
wfm 2004050422 trunk linux

Comment 2

14 years ago
WFM, Win2k, 1.7rc1 and FireFox 20040426 

Comment 3

14 years ago
By the way, this is not exactly a blocker!

Updated

14 years ago
Severity: blocker → major

Comment 4

14 years ago
Confirming behaviour on http://www.jiffymade.com/dev/dn/renter2.htm
using trunk Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040505
Created attachment 147812 [details]
Simpler testcase based on site

I can confirm, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040505
Firefox/0.8.0+

This is a simpler testcase. The testcase needs to have the position:relative
for the span in which the select gets written with innerHTML, otherwise you can
open the select box directly. 

By the way, this testcase somehow manages to crash my Mozilla/Firefox browser.
Talkback ID: TB40072G

Comment 6

14 years ago
Created attachment 147934 [details]
reduced testcase

It has nothing to do with dynamically generated content. Rather, if you have an
inline element set to position: relative, inside it a block-level element, and
inside that a select, the select won't drop down.
Attachment #147812 - Attachment is obsolete: true

Comment 7

14 years ago
This isn't really major, in my opinion.

Jon, I'm assuming you're the webmaster of that site. This can be solved by not
putting a block level element (such as table) inside an inline element (such as
span). In short, change the span to be a div and it should work.

Martijn, I can't find that talkback ID at http://talkback-public.mozilla.org/ .
Are you sure you copied it down right?
Severity: major → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Updated

14 years ago
Summary: Select form field not selectable when written dynamically to <span></span> → Select dropdown does not drop down when inside a block-level element which is inside a position: relative inline element

Comment 8

14 years ago
Martijn's stack is now up at
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB4007

From Martijn:

I don't get a crash from a debug build of the Mozilla 1.7rc1, but with clicking
on test1 or test2, I get an assertion:
ASSERTION: frame was not removed from primary frame map before destruction or
was readded to map after being removed:
'!PL_DHASH_ENTRY_IS_BUSY(entry)||entry->frame!=aFrame',file
c:/mozilla/mozilla17/layout/html/base/src/nsFrameManager.cpp, line 780

I get that warning 12 times in a row.

This is on my windows2000 machine. On my windowsXP machine I have never been
able to get that crash, however.
I'm not sure what I must do with such a vague crasher. It doesn't crash easy,
you know, I have to click quite some time, befor it crashes on me (20 times or
so, not sure what triggers the crash) 
Thanks Jason.
But the TB is TB40072, not TB4007.
This is the good link:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB40072

Comment 10

14 years ago
*** Bug 248126 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
*** Bug 278439 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 241638 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.