Popup menu highlight is blue when system is set to 'Graphite'

RESOLVED WORKSFORME

Status

--
trivial
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: brion, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040505
Build Identifier: version 0.6 (20040502)

OS X's Aqua interface can be set in either the default "Blue" theme or a gray
"Graphite" variant. Thunderbird in the Pinstripe theme gets most UI elements
correct, but the background for highlighted items in popup menus are always
rendered with the blue appearance. In "Graphite" it should display in a dark gray.

This is reported for Firefox as bug 235031.

Reproducible: Always
Steps to Reproduce:
1. In system 'Appearance' panel, select "Graphite"
2. Launch Thunderbird
3. Ctrl+click in message area to pop up a menu
Actual Results:  
Popup menu highlight background is blue.

Expected Results:  
Popup menu highlight background should be dark gray like in the main menubar.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

13 years ago
This is not a dupe of bug 240320; text highlight color and menu highlight color 
are not related on the Mac.

Anyway it seems to be fixed in TB 1.5 beta 1, so resolving as FIXED. Yay!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

13 years ago
We don't know what fixed this worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.